Whenever I try to log into Skype in Ubuntu 11.10 64-bit, it always says "Sign in failed" and "Another Skype instance may exist", thus preventing me from being able to log in.

I've had this kind of error in the past on previous Ubuntu releases where I would forget I already had Skype running and try opening it in the Dash again, and it was easily solved by just closing the extra window. But this time is different, and much more frustrating, because I get this error even after starting from a cold boot or running killall skype...times when AFAIK Skype should not even be running at all. Skype doesn't even show up in the Processes tab of System Monitor before I try starting it up, so I am pretty sure there is no second instance running.

I am using the version of Skype from the Ubuntu Software Center. I have already tried reinstalling it to no avail. Any other suggestions?

Other things I've tried:

Tried the first answer to be posted to get the following output:

christopher@Xyz:~$ ps -ax | grep skype
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
10072 pts/0    S+     0:00 grep --color=auto skype
christopher@Xyz:~$ kill -kill 10072
bash: kill: (10072) - No such process

I have also tried a suggestion from the comment to this answer for a very similar problem (specifically, running pkill skype and pkill -9 skype), but that didn't work either.

| improve this question | | | | |

You can try deleting your ~/.Skype folder (remember to backup first). This usually fixes any problems of this kind.

According to sixones:

Rather than wiping the entire folder, you can close Skype and delete these files; ~/.Skype/shared.lck, ~/.Skype/username/*.lock, ~/.Skype/username/*-journal. Deleting them all clears out the lock and keeps your chat history and preferences.

You can do this by running the following command in a terminal:

rm ~/.Skype/your-username-here/shared.lck, ~/.Skype/your-username-here/.lock, ~/.Skype/your-username-here/*-journal

Where "your-username-here" is your Skype username.

You can also use the file manager to do this. Simply navigate to your ~/.Skype/your-username-here folder and delete the files manually.

| improve this answer | | | | |
  • It made me run through the EULA again and have to reset all my options, but otherwise worked like a charm! – Christopher Kyle Horton Oct 7 '11 at 1:31
  • @WarriorIng64: you did backup the folder though, correct? – RolandiXor Oct 7 '11 at 2:25
  • Yeah, but after seeing that everything was working I decided not to keep the backup. It seems after restarting Skype that it has created a new .Skype folder anyways. – Christopher Kyle Horton Oct 7 '11 at 2:31
  • 2
    @WarriorIng64: oh well, the next time you need to do it, you can preserve chat logs etc, but I guess you don't need to lol. – RolandiXor Oct 7 '11 at 12:52
  • 2
    Rather than wiping the entire folder, you can close Skype and delete these files; ~/.Skype/shared.lck, ~/.Skype/username/*.lock, ~/.Skype/username/*-journal. Deleting them all clears out the lock and keeps your chat history and preferences. – sixones Feb 22 '13 at 11:49

You can see if another skype instance is running if you type ps -ax. If you see a skype instance in the list, you could try to kill it with kill -kill XYZ. XYZ would be the pid - a most number with 4-5 digits. Good luck - maybe it works ;)

| improve this answer | | | | |
  • Nope, didn't work. I'll post my output in an update to my question. – Christopher Kyle Horton Oct 6 '11 at 12:44
  • ps -ax alone should do fine. I get the same result as you did, when I type ps -ax |grep skype. Well I guess you have to scroll a little bit. – Ewald Oct 6 '11 at 13:52
  • Ok I tried. If you run a skype session, the output would be sth like: 17261 ? Sl 0:03 skype 17305 pts/0 S+ 0:00 grep --color=auto skype So there is no skype process running your computer whatsoever. Maybe it is an Internet connection problem - sth like a firewall. Sorry I can't help you more :( – Ewald Oct 6 '11 at 14:42
  • I do have a working wireless Internet connection and I haven't set up my firewall just yet. But thanks anyway. – Christopher Kyle Horton Oct 6 '11 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.