3

Since Elementary OS is a Ubuntu based distribution I think it should be fairly easy to install a stable version of Pantheon on Ubuntu (in my case 14.04). I have seen that many people have tried and there are lots of solutions but almost all of them are outdated or suggest pulling a unstable version of Pantheon from the test repository of Elementary.

I tried the following, but it does not work. (resource here)

$ sudo add-apt-repository ppa:elementary-os/stable
$ sudo apt-get update
$ sudo apt-get install elementary-desktop

However the above leads to a disaster. Somehow Pantheon installs over Unity and the result is a strange mixture between them - The unity launcher with the Pantheon icon pack and font. Of course I tried to log out in order to select the Pantheon shell but it was missing from the list with desktop environments (a system restart did not help as well). Luckily I managed to delete Pantheon and now everything is back to normal but I would like to be able to run it.

TL;DR Is there a way to install a stable version of Pantheon as a separate desktop environment on Ubuntu 14.04?

  • 3
    Note to the close voters: This is a question about Ubuntu and how to install an additional Desktop Environment on 14.04.2 LTS. This question is not about Elementary OS Luna – Fabby Jul 8 '15 at 8:54
1

You must use these commands:

sudo add-apt-repository ppa:elementary-os/daily
sudo add-apt-repository ppa:elementary-os/testing
sudo add-apt-repository ppa:elementary-os/os-patches
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install elementary-desktop

[ Source: https://www.youtube.com/watch?v=L5dK74bnBOY ]

  • Thank you for the answer but I am afraid that I am searching how to install a stable release of the Pantheon shell, as stated above in my question. The daily and testing repositories provide unstable packages. See the official information at launchpad here and here. – 0x450 Jul 5 '15 at 17:59
1

After being in your same boat, and not finding terrific answers, I think I have figured out why you (and I) were having issues: Freya is only on Trusty. This means that if you're running a version above what is listed, the ppa will point to a non existent repository by default.

So executing this:

sudo add-apt-repository ppa:elementary-os/stable

Will look like this, once installed:

http://ppa.launchpad.net/elementary-os/stable/ubuntu/wily/main

Which currently does not exist.

I'm assuming that at the time you tried this, Trusty was not considered stable yet.

So, to avoid this, make sure you add the version you want. I'm not enough of a BASH hound to know how to do this from the terminal. The command listed on the eOS launchpad doesn't seem to work for me.

BUT, you can acccomplish the same thing in Synaptic. Go to the repositories by clicking Settings>Repositories and go to the Elementary OS repo and click "edit". Under version, change it to Trusty instead of your version.

I should mention that this may be why people are recommending using the daily instead of the stable. eOS seems a little behind the main distro on releases (understandable), so just because you're on the latest stable Ubuntu doesn't mean that's the latest stable eOS.

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.