1

Recently, I've downloaded latest android-studio for Ubuntu. The problem is, it takes forever when it start compiling. The error message says,

Gradle executing tasks

But, when i stop android studio, it says,

Gradle successfully finished.

So, what causes this error? Is this error from my side or from android studio?

2

I too had the same error. The libz.so.1 was missing.

Fixed this by

sudo apt-get install lib32z1
0

In my case i already had lib32z1 installed.
The problem was Genymotion plugin. Once i removed it from studio and restarted. It worked fine.
I still don't know how that could happen as i regularly use genymotion with studio in my other machines.
You can still run genymotion even if you remove studio plugin by starting emulator from genymotion itself.

0

First sync with the grade files and then check the grade console for some errors. I had two applications aapt and zipalign being blocked by the ubuntu bash. You have to go to your SDK folders and check for the appropiate build-tools(for mine it was 23.0.2, you can find this in the grade console while file sync) and then mark the files as "Allow Executing Files as Program". Hurray, it worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.