2

(I also posted this in the Unix/Linux Stack Exchange. Not trying to spam you guys, just not sure where to post). I just installed Ubuntu 14.04 MATE on a Dell 11 Chromebook, and since booting for the first time, the touchpad has stopped responding unless I use the pad of my finger.

Before wiping the SSD and installing MATE I had been running Ubuntu XFCE alongside Chrome OS using Chrouton, and the touchpad worked like a dream. But since installing MATE I've been experiencing the weirdest issue. The touchpad reacts to pad of my finger - where the fingerprint is - but not the tip: If I use the pad of my finger to move the cursor, it works OK. But if I use the tip of my finger (the part you usually use to tap a touchscreen, and the part you normally use to move the cursor with a touchpad), the cursor won't budge. And even when I use the pad of my finger, the cursor doesn't always register the contact.

It seems that more finger surface has to be in contact with the trackpad for it to register. I've tried every combination of acceleration, speed, and sensitivity in the mouse settings and in gpointed, turned off "disable touchpad while typing," etc, but nothing works. According to xinput list it's a Cypress APA Trackpad.

Here's the full output of xinput:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Cypress APA Trackpad (cyapa)              id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

EDIT: I tried adding a regular physical mouse, and it works fine. But I don't think my problems are caused by a hardware malfunction, because the touchpad was working fine yesterday when I used Chrome OS and XFCE.

  • Please edit your question and add output of xinput command. – Pilot6 Jul 14 '15 at 18:07
4
+50

Figured it out! As per this Arch Linux installation tutorial, I edited my /etc/X11/xorg.conf.d/50-cros-touchpad.conf file and added Option "FingerLow" "5" and Option "FingerHigh" "10". Now the touchpad works just fine! Here's the full output of 50-synaptics-conf:

# Additional options may be added in the form of
#   Option "OptionName" "value"
# See man synaptics (4) for details

Section "InputClass"
 Identifier "touchpad ignore duplicates"
 # Ignore events from old driver
 MatchIsTouchpad "on"
 MatchOS "Linux"
 MatchDevicePath "/dev/input/mouse*"
 Option "Ignore" "on"
EndSection

Section "InputClass"
 Identifier "touchpad catchall"
 # Device
 Driver "synaptics"
 MatchIsTouchpad "on"
 MatchDevicePath "/dev/input/event*"

 # sensitivity
 Option "FingerLow" "5"
 Option "FingerHigh" "10"

EndSection

# End of configuration file

It's strange that editing the sensitivity settings using gpointed didn't work.

0

it is probably because you need a better driver for Ubuntu mate to better utilize the touch pads functions. It could be that the OS doesn't sufficiently sense the motion from the touchpad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.