0

I'm unsure whether this is a driver problem or a wifi signal problem.

Broadcom wifi won't connect in room router is in but will in another room further away

N.B. Sometimes it will connect - but the connection is lost just quarter of an hour roughly after.

Only applies to one laptop "Acer 5742z". Works okay on Nexus 7. Motorola G 4G.

I am using channel 7. Only one other network shows up on channel 7 with low signal strength compared to my own network. "InSSIDer" My network shows -40dB and my neighbours are -90dB . Two at those levels.

Link to suggestion solution from askubuntu when posting question. Steps that I HAVE tried to implement - but with no success

lspci -vnn | grep Network

02:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)

14e4:4357           Special Case #1                   UNKNOWN

Special Case #1 - Uses bcma and brcmsmac driver combination. Required firmware is installed by default in the package linux-firmware.

I've tried a live usb 14.04.01 stick. At first it connected easily but gave a download speed of 8Mb/s. I have a connection of up to 100Mb/s. Prior to the failure/dropping of the signal yesterday I was getting 60-80Mb/s. My tablet (Nexus 7 2013) receives 50Mb/s in the same room connected to the router run just 10 minutes apart. I have a repeater also on channel 7.

It has working fine for the last year. I had previously had the same problem and just moved to channel 7 which fixed it. But this time this seems to be the best channel anyway. After changing to 1 or 12 it does not improve. Just tried bcmwl-kernel-source. In the process of following the link above I have disabled my wifi completely. I tried keying in the rfkill and blacklist.

The below is the output from lspci -knn | grep 0280 -A2

02:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01) Subsystem: Foxconn International, Inc. T77H103.00 Wireless Half-size Mini PCIe Card [105b:e021] Kernel driver in use: wl

Hope someone can advise?

3
  • Let's see what driver is in place. Please edit your question to add the result of this terminal command: lspci -knn | grep 0280 -A2 Welcome to askubuntu.
    – chili555
    Commented Jul 4, 2015 at 18:22
  • You need to understand that channel interfere each other. If you have a strong neighbor signal at 6th channel, you 7th won't work well. It is better to use 1, 6, 11 channels, because others almost make no sense.
    – Pilot6
    Commented Jul 4, 2015 at 18:39
  • I tried all Channels and the laptop showed no real improvement @Pilot6 Sometimes it will run at 80Mb/s other times it connects to the router but seems to have no internet connection.
    – user335306
    Commented Jul 5, 2015 at 10:56

1 Answer 1

0

You can try to use a proprietary Broadcom driver.

Broadcom claims that it works for your adapter, but this claim is not very reliable ;-)

Install it this way

sudo apt-get install bcmwl-kernel-source

It if does not work, you can always remove it by

sudo apt-get purge bcmwl-kernel-source
0

You must log in to answer this question.