5

There seem to be many problems with keyboard layout switching in Ubuntu.

For me (Ubuntu with Gnome Shell), it used to work until version 13.10, maybe 14.04. Currently I am on 15.04.

Even then Alt+Shift would work but for some reason layout started to switch also using Left Shift+Right Shift which is greatly annoying because I tend to press this combination inadvertently when typing.

In Settings -> Keyboard -> Shortcuts -> Typing, "Modifiers-only switch to next source" is set to Alt+Shift. All the other options there are unset.

Where else can you set the layout switching shortcuts?

In some questions and answers I see people referring to the "Text Entry" app - I don't see it anywhere, I guess it was changed in later versions?

Also, I don't know if this is related, in "Input Method Configuration", I see the following:

Active configuration: ibus (normally missing)
Number of valid choices: 2 (normally 1)
Available input methods: ibus xim
Unless you really need them all, please make sure to install only one input method tool.

Input Method Configuration window screenshot

Another problem is that the switching layouts doesn't work well. Sometimes I have to switch three times before it actually switches. Also the indicator shows the wrong language. I usually have two layouts: en and cs. Sometimes the indicator shows en while the layout is cs, or even the other way around I guess. It's all just a mess.

Is there a way to reconfigure/reset the layout switching, a way to start from scratch?

Is there some official Ubuntu guide? Does it work better in other distros? Maybe there's a relevant guide for ArchLinux?

1

Yes, that setting was for old releases (if i remember <13.10) which expect only one input method (xim). It is still used for Xubuntu & Lubuntu. For Ubuntu/Gubuntu, You are right the new setting is:

Settings → Keyboard → Shortcuts → Typing

I see you are using ibus as default input method. So some shortcuts may override by ibus because it has its own settings and can filter input.

If you have to use ibus for CTL language input, check it configuration ibus-setup, probably these below options are related, however check all settings:

  • Advanced tab → Use system keyboard layout
  • General tab → Net input method shortcut

Also check that all you GUI kits (GTK, QT ..) use same input method:

env | grep -i im

If you don't really need it disable ibus (Also you may disable it just to test, if the issue originates from it)

0

Thanks to details in Debian wiki Keyboard topic, I often use the following command to reset compose:ralt layout option when switching between keyboards layout:

sudo udevadm trigger --subsystem-match=input --action=change

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.