8

I'm trying to install dotnet4.5 using winetricks on Ubuntu12.04 64bit. It keeps on giving me "Mono does not appear to be installed " error though i have mono installed . I ran these two commands to get mono and mono-complete

sudo apt-get install mono

sudo apt-get install mono-complete

wine version i am using is Wine 1.6. I have already Tried reinstalling wine . Its not just dotnet4.5 but all the versions of dotnet give me the same error .

5

http://dl.winehq.org/wine/wine-mono

d/l the latest version and place the .msi into /usr/share/wine/mono

then continue with installation of dotnet45

| improve this answer | |
3

Do the below to install wine-mono.

  1. Download wine-mono.msi from the official winehq site.
  2. Type wine64 uninstaller.
  3. Press install from the uninstaller GUI and select the downloaded .msi package.
  4. Done!
| improve this answer | |
2

I believe that you don't need Mono. The WineHQ wiki page for Mono says:

The Mono package should always be removed before installing native .NET. This can be done with the following command-line:

$ wine uninstaller --remove '{E45D8920-A758-4088-B6C6-31DBB276992E}'

That page also explains the installation of Mono for Wine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.