2

Following this answer I was able to restore hibernation on my Ubuntu Vivid Vervet 15.04. Unfortunately after hiberate/restore all running programs are gone, as if it was a regular power-off.

Any hints?

Edit:

sudo blkid

/dev/sda1: UUID="c5d5f237-f70c-43db-bbeb-482b8c15bf33" TYPE="ext4" PARTUUID="559a5acb-01"
/dev/sda5: UUID="60a90294-7412-47fc-99e3-f2c69a9b1db0" TYPE="swap" PARTUUID="559a5acb-05"
/dev/mapper/cryptswap1: UUID="6d0b5a7c-f404-47e9-a641-b04dcde3a5c2" TYPE="swap"

cat /etc/initramfs-tools/conf.d/resume

RESUME=UUID=645b50f6-d568-4247-9f7b-a6bd07b21686
  • Do you have a swap partition? What is it size? What is your RAM size? – Pilot6 Jul 3 '15 at 16:14
  • @Pilot6 I have a 4.2 GB swap and 3.8 GB RAM – alex Jul 3 '15 at 16:21
  • 1
    Please edit your question and add output of sudo blkid and cat /etc/initramfs-tools/conf.d/resume terminal commands. – Pilot6 Jul 3 '15 at 16:26
  • @alex does this still happen when running sudo pm-hibernate? – Grammargeek Jul 3 '15 at 16:45
  • What is your "cryptswap" partition for? – Pilot6 Jul 3 '15 at 16:59
2

You hibernation does not work because you have a wrong UUID in your /etc/initramfs-tools/conf.d/resume file.

Run in terminal

echo "RESUME=UUID=60a90294-7412-47fc-99e3-f2c69a9b1db0" | sudo tee /etc/initramfs-tools/conf.d/resume
sudo update-initramfs -u -k all
  • But I am concerned about "cryptswap". Is your swap partition /dev/sda5 or you have an encrypted swap? – Pilot6 Jul 3 '15 at 16:57
  • this does not work for me - the same problems occur. do you have any other ideas? – alex Jul 4 '15 at 4:59
  • The idea is same. System must know from what partition to resume. If swap is encrypted, that may be an issue. If you do not need an ancrypted swap, i would remove it and update /etc/fstab and other settings. – Pilot6 Jul 4 '15 at 8:18
0

At the Official Ubuntu Documentation, it is already warned that hibernation may not work as expected, and suggests that test run before activating, and always save the work you are doing.

This is why the feature is not enabled by default.

  • That is true, but it works in most cases. – Pilot6 Jul 3 '15 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.