1

I seem to have a problem with the drivers. I tried everything. Every single fix that I found on this forum and I can't install the proprietary graphic drivers for my ATI Radeon HD 5470.

When I go to additional drivers - I have 3 options:

  1. Default
  2. Fglrx
  3. Fglrx-update

Whenever I try to install some of the 2 or 3, When i restart my laptop, it gives me error:

Low graphic mode

and I can't start my pc unless I boot into recovery and remove the whole Fglrx packages.

I tried downloading and installing from the ATI website, no luck. Still the same error. Can someone tell me what am I doing wrong?

1

I had exactly the same problem. I used the following technique

Firstly remove all previously installed drivers :

sudo apt-get remove --purge fglrx fglrx-amdcccle

Now install them fresh :

sudo apt-get install fglrx fglrx-amdcccle

After the installation is done use the command given below

sudo amdconfig --initial

Now reboot your system. Your computer will have drivers and Catalyst Control Center. As the command sudo amdconfig --initial is very important as i found it on amd web site some while ago.

Note: if you don't want to waste lots of time on downloading and installing firstly try this command sudo amdconfig --initial and restart. It may work. But i had to uninstall everything so use the whole post i described.

It should definitely work. Best of luck

1
  • I appreciate your help, but this is not working for me. I get the same error. – boka18 Jul 14 '15 at 15:51
0

I have had same problem first you have to install flgrx update, and then reboot it give the error, and then you have to enter the tty push Ctrl + alt + f6, and then you have to type this in the tty:

     sudo apt-get install lxde

and then this

     startx

and it starts the LXDE, and then enter start button and use preferencs, and then the upper gfx card Adm menu, and set every thing to default, and then you can reboot and Ubuntu works whit the flgrx update.

2
  • Let me check it out. I will update you soon! – boka18 Jul 2 '15 at 18:23
  • @boka This answer has not solving your problem. It installed a different desktop environment. But it is not related to video drivers at all. – Pilot6 Jul 4 '15 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.