2

So, I have installed ubuntu on my SSD along with Windows 8.1. I have used three partitions for Ubuntu: swap, /, /home. All was fine until I had to shutdown or restart. It hangs/freezees every time. I've searched for solutions and tried them all but to no avail.

So I came up with the ideea to put ubuntu on separate disk, a HDD. Did that, and placed Grub bootloader on the second disk. To my surprise, Ubuntu works perfectly from the HDD. No shutdown or restart issues.

UPDATE 1
I reinstalled Ubuntu on the second Disk (HDD) and it started to behave exactly as on the SSD. I try to restart or shutdown and immediately it freezes and I cannot do anything unless I force shutdown.
Is there anything wrong with my current install or it's just something related to my computer?

Edit I get same issues from the Live USB (Try Ubuntu)!

UPDATE 2
Ubuntu 15.04 live USB: same shutdown and restart problem.

So it seems that it is something related specific with my system. But what is it?

UPDATE 3
Reinstalled Ubuntu, and now I have Grub on my EFI partition. Also, removed the second HDD (from the DVD bay), so now I have only Windows 8 and Ubuntu 14.04 installed on the SSD. I have also re-did the boot-info and updated the link.
Now, another problem is that I have started to get kinda randomly freezes and 100% hangs at shutdown and restart. It's just getting to the point of getting to my nerves! What is going on of this whole mess?


Boot-info report: http://paste.ubuntu.com/1181907689/


My system:
Laptop Asus N56jr, Intel i7 4th gen, 16GB RAM, 500GB Samsung 850 Evo, Nvidia GeForce GTX 760M.

Os: Windows 8.1 and Ubuntu 14.04

Currently, I have the latest Bios update and could not find any update for my SSD firmware.

  • Most of the Intel updates are in the current version of 14.04, but 15.04 may have just a few more updates. What kind of errors are you getting? What video chip does your computer use? Post the link to the Create BootInfo summary report. Is part of Boot-Repair: Just to confirm how install(s) look. help.ubuntu.com/community/Boot-Info – oldfred Jul 3 '15 at 20:45
  • Here is the link. I've also edited the post: paste.ubuntu.com/11817483 – Cristian Jul 3 '15 at 21:20
  • You have MBR(msdos) partitioning on sda and gpt(GUID) partitioning on sdb for Windows to boot in UEFI boot mode. For install on sda, you do not have grub installed to MBR. But mixed booting is difficult, better to convert sda to gpt. And you do not show grub boot files in sdb's efi partition. Grub really defaults to sda for its install and would expect an efi partition on sda. I even tried to install grub to sdb and it would not. To get SSD to work better to swap drives SATA ports on motherboard so SSD is sda. Not sure if that causes Windows issues, check that first. – oldfred Jul 3 '15 at 22:35
  • @oldfred But sda is my DVD bay where I have a Hdd caddy for the HDD and my SSD is installed in the normal sata port as sdb. Anyway I had tried the install without the hdd caddy (only had SSD disk in) and had same problems. Right now, I had cleaned my Ssd efi partition (from Windows recovery USB) and that is why grub does not show on the SSD. – Cristian Jul 3 '15 at 22:37
  • System should not make DVD bay sda. And some systems will not boot from a DVD caddy's drive even though they boot a DVD?? You need to get grub back into ESP - efi system partition. If you repartition drive in DVD caddy to gpt and create an efi partition as the first partition, grub will install to it. You may be able to just copy the /EFI/ubuntu folder from sda to sdb, or grub/ubuntu may boot from sda then. – oldfred Jul 3 '15 at 22:46
0

So, after lots and lots of tests I may have figured it out. I updated the kernel from 3.16 to 3.18 and then I also installed the latest Nvidia driver tha shows in the Ubuntu Software Center. Although it's not the latest Nvidia driver I think that was my problem to begin with.

I also tried installing the latest Nvidia straight from the Nvidia website but I just get error after error. First it tells me that I don't have the right GPU for the driver, then I got the runnig X server and then something related to a failed script.

So, right now I will try Ubuntu like crazy and see what happens next.

UPDATE - Victory!!! - Nvidia updated driver solved my problems
I just reinstalled Ubuntu (just for the sake of finding out what was going on) and of course the shutdown/restart hang reappeared. That meant I could recreate the problem. So, I tried restarting a few times with no success. Then, I did a Software Update which installed a bunch of updates but kept my the current 3.16 kernel. And shutdown and restart were still not working. I then went to Additional Drivers and updated the Nvidia driver to the proprietary and tested driver. Restart and VOILA!!! Is working fine. In the end the 3.18 kernel did nothing to help my problem!

So, if you are having Ubuntu freezes/hangs while trying to restart or shutdown, there's a big chance you are having some kind of driver problem!

  • With nVidia, first choice is always to install from Ubuntu's repository. But some very new cards/chips need the newest nVidia driver. Then better choice is to use a ppa which has newest drivers and also then integrates it into Ubuntu like installs from repository. If you install from nVidia directly you in effect have to reinstall on every kernel update as it is not automatically included. – oldfred Jul 4 '15 at 15:03
  • @oldfred I actually found about what you said and installed it from Software and updates - Additional drivers (if that is what u were talking about). So far I've rebooted and shutdown my laptop for at least 30 times and no issues. Is there any way to pinpoint if the problem was the kernel or the nvidia drivers? – Cristian Jul 4 '15 at 16:59
  • Do not know how to really find issues. Sometimes fixes are just sprinkling magic dust on computer & then it seems to work. :) – oldfred Jul 4 '15 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.