4

I tried to connect my brand new Microsoft Lumia 540 to Lubuntu 14.10 with the help of default LUMIA USB cable and got the following error messages.

  1. Unable to Open MTP devices
  2. Couldn't find matching udev devices

Then, I tried to install the missing software component MTP TOOLS through the terminal window;

sudo add-apt-repository ppa:webupd8team/unstable
sudo apt-get install mtp-tools mtpfs

And the MTP TOOLS installed successfully. And I restarted my desktop PC and tried to connect my Lumia 540 again. Still, I am getting the second error message "Couldn't find matching udev devices"

I removed the memory card from the mobile and connected again. Then, I got the same error message. I do not know, why? Please help me to connect this Microsoft Lumia 540 mobile phone to Lubuntu operated PC.

  • Could you post output of sudo lsusb with phone plugged in – user.dz Jul 18 '15 at 10:23
  • Okay, I can do that soon ... – Kannan Soorej Jul 18 '15 at 11:42
  • Another thing, the ppa you have mentioned does not contains mtp-tools & mtpfs , are you sure it's the correct ppa? or could you point me to the reference you are flowing its instructions? Please, make an edit to your original post see edit link at the bottom of your question. – user.dz Jul 18 '15 at 12:01
  • 1
    Have you tried enabling USB Mass Storage in your phone's settings? (Sorry for the late answer, I'm just going through trying to clean up some old questions that don't have answers.) – KGIII Oct 18 '15 at 22:21
  • Please do not tell me sorry for your late answer .... It's Okay .... Now, I have no memory card inside my Lumia 540 Phone (it was an old memory card and it became faulty and unable to use it now) Still it shows me the same errors without the SANDISK 4GB memory card .... – Kannan Soorej Oct 19 '15 at 6:22
2

I just had exactly the same error but with my ASUS Zenfone 2 on Xubuntu 15.10.

I tried a different USB port (3.0) and it just worked, I suspect the MTP setting wants a better port. Either that or there is something wrong with my USB 2.0 port (and the OPs port)

You could try a different port - on a different PC if you have to.

  • Worked for me too. But wish was something more log losting. Had to restart my phone after a while, then my ubuntu. – tgkprog Jul 22 '16 at 13:50
0

ubuntu 16.04 I got these same error messages. I installed a number of mtp apps as described variously (including mtp server, which seemed not to have been mentioned iirc) however the phone kept repeatedly mounting and unmounting... I was using a long usb cable, I tried two cables. I tried different usb ports. All fail. Only got immediate success when using a short usb cable (less than 30 cm long)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.