7

I've never used "Desktop" folder in my home directory for anything and I would like to remove but it always recreates itself when I delete it or hide it. It's pretty sticky.

I've also tried include folder into .hidden file, editing user-dirs.conf in /etc and /etc/xdg but with no success.

It reminds me every day that I'm not able to get rid of it :-)

Thank you for any information.

  • Actually that's what I did and it did not work. – Sebastian Jul 1 '15 at 18:09
  • AH, sorry, I read over it... – Jacob Vlijm Jul 1 '15 at 18:10
  • Edit your question and add your used steps. – A.B. Jul 1 '15 at 18:41
  • Here's what you need superuser.com/a/298744/418028 . Just remove a folder from the ~/.config/user-dirs.dir file or disable automatic updating of user directories – Sergiy Kolodyazhnyy Jul 1 '15 at 20:17
6

There are two possible solutions (as far as I can tell):

Move the Desktop folder

  1. Open the file ~/.config/user-dirs.dirs in a text editor
  2. Change the line XDG_DESKTOP_DIR="$HOME/Desktop" to point to some other location
    (for example: XDG_DESKTOP_DIR="$HOME/.config/desktop")
    • Do not just remove the line:
      Doing so will make it use the default value ($HOME/Desktop) and you'll end up in the same situation that you are already in :-)
  3. Save the file
  4. Log out and back in

Screenshot after editing and applying the change

Disable the desktop entirely (advanced)

This is a more advanced method that will disable desktop management entirely (including desktop folder creation and display).

  1. Launch a terminal (if you don't know how than this isn't for you)
  2. Type in this command: xfconf-query --channel "xfce4-session" --property "/sessions/Failsafe/Client4_Command" --type string --set ""
    • Basically it tells the session manager (the thing that starts and monitors your desktop and window manager, panel, ...) to not start any desktop manager ("Client2") anymore
  3. Log out and back in

If you wish to re-enable desktop management later on, do the same steps as above but use the command xfconf-query --channel "xfce4-session" --property "/sessions/Failsafe/Client4_Command" --type string --set "xfdesktop" instead.

| improve this answer | |
  • Don't forget to upvote and mark as accepted answer if this helped you! Do ask for clarification if something doesn't make sense to you! – ntninja Jul 1 '15 at 21:28
  • Fantastic, Alexander, you solved it for me. Thank you so much for your answer! – Sebastian Jul 3 '15 at 18:20
-1

Note: I tried the "Move the Desktop Folder" solution in 16.04 and it resulted in turning my desktop empty. (i.e. solid black) Currently working on resolving this, simply reverting the change to the config file does not work.

Update: Problem resolved with a reboot, following a re-edit to the config file.

| improve this answer | |
  • Could you be a bit more precise on exactly what the OP has to do? – anonymous2 Aug 20 '16 at 1:59
  • 1
    My post was not directed at advising the OP, but more at anyone else who may find this discussion and want to attempt the provided solutions. If you mean that you want my explanation to be more precise, then I am happy to oblige: after encountering the problem I described (of my desktop background disappearing) the problem resolved itself once I had re-edited the config file so that it was identical to what it had been before, then rebooting the computer. – Christian V Aug 22 '16 at 20:56
  • That's great, thanks! Askubuntu.com is aimed at providing clear questions and answers, unlike many forums, where discussion is acceptable. – anonymous2 Aug 23 '16 at 2:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.