33

I use htop in a terminal but I can't close it with F10. F10 seems to just open a program's File dialog. Is there a way to disable it so I can close htop normally?

31

You always can have the interupt signal keys Ctrl+c.

Basically Ctrl+c sends the SIGINT (interrupt) signal, ; by default, this causes the process to terminate.

Just like top, htop can be quit by pressing Q.

SIGINT

The SIGINT signal is sent to a process by its controlling terminal when a user wishes to interrupt the process. This is typically initiated by pressing Control-C, but on some systems, the "delete" character or "break" key can be used

| improve this answer | |
  • If you exit htop with Ctrl+C (SIGINT), htop will exit with a failure status (status code 1) and will not save any settings (like the sort column, etc.). – Léo Lam Jul 2 '15 at 12:13
34

TL;DR The standard way to quit htop is F10 or q.


Therefore if you can't use F10, use q (lowercase).

enter image description here

| improve this answer | |
  • Note that this is a lower-case q, not a capital one. – Lekensteyn Jul 1 '15 at 15:38
11

If you are using gnome-terminal, yes, you can disable that the F10 key opens the menu:

Open gnome-terminal's menu with F10 or with the mouse, select Edit > Keyboard Shortcuts, then uncheck "Enable the menu shortcut key (F10 by default)".

| improve this answer | |
  • 2
    This is not a gnome-terminal issue. F10 seems to do the same annoying thing for any program and there doesn't even seem to be a shortcut registered in the Gnome shortcut settings :( – Pithikos Jul 2 '15 at 10:55
  • Solution worked for me. As of Ubuntu 18.04 setting was in Edit > Preferences > General – Den Kasyanov Apr 3 at 13:37
2

All sorts of other options apart from q.

  • Open another terminal and kill it from there.
  • Kill it from the System Monitor task list.
  • Close the terminal window.

These assume a desktop environment.

Also for servers...

  • Ctrl-Alt-F1 (or F6/F7) and log in again to kill.
  • Connect again (Telnet/SSH) and kill.

And finally - it is open source, patch it.

| improve this answer | |
0

If you're interested in making F10 (and other shortucts) available in general to terminal applications and you're using XFCE terminal, go to Edit -> Preferences -> Advanced -> Shortcuts and check the appropriate boxes to disable the keys. I have them all checked so that Emacs (m-f) and htop (F10) will work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.