42

I've installed VirtualBox (with Ubuntu 14.04 Desktop) and Guest Additions on my Windows 7 machine.

Every time it boots up I get the following error message which goes away:

vboxclient the virtualbox kernel service is not running. exiting.

How can I disable this message? I've tried the following:

I deleted /etc/xdg/autostart/vboxclient.desktop file.

But I am still seeing the message when logging in.

Any suggestions on how to fix this?

29

Try eject the VBOXADDITIONS cd image on ubuntu and "insert" it again from Vbox menu. I was just having this same problem and doing this fixed it.

| improve this answer | |
30

This usually happens when you update the Guest's Linux Kernel.
After each update, you need to do:

  • For Host (installing server)

    sudo /etc/init.d/vboxdrv setup
    
  • For Guest (installing additions)

    sudo /etc/init.d/vboxadd setup
    

The reason why inserting the VBox addition disk again works is because that's one of the things the installation procedure does as well.

| improve this answer | |
  • 1
    Thanks, this was exactly the problem for me. Guest Ubuntu updated and then this error was showing. Running the guest command fixed it. – Flupkear Jun 27 '16 at 15:30
  • 1
    On Mac OSX El Capitan the host command doesn't work, but reinstalling the cd image and running the guest command does. – mstreffo Jul 19 '16 at 12:35
  • 14
    I'm getting sudo: /etc/init.d/vboxadd: command not found – HelloGoodbye Nov 21 '16 at 15:16
  • Great! It was enough to execute setup on Guest side for me. – user1984631 Jan 13 '17 at 8:54
  • 2
    @HelloGoodbye, had the same issue, reinstalling Linux Additions helped me get rid of the error vboxclient the virtualbox kernel service is not running. Follow instructions here virtualbox.org/manual/ch04.html#additions-linux Do not forget to reboot the VM. – andrybak Mar 13 '19 at 14:12
3

I'm running Ubuntu 15.04 on Virtualbox 5.02. The same notification went away after I selected two "restricted drivers" from Virtualbox.

More specifically, from Software & Updates > Additional Drivers tab, there are two drivers previously not selected: Using x86 virtualization solution - X11 guest utilities from virtualbox-guest-x11 and Using x86 virtualization solution - guest addition module source for dkms from virtualbox-guest-dkms. The notification was gone after I selected to use these two proprietary drivers.

Update: one of these two drivers seem to cause a repository inconsistency when I run apt-get update. I chose to use the package maintainer's version to solve the inconsistency, and haven't run into any further problem.

| improve this answer | |
1

If you just want to prevent this warning from showing when you boot up your system, follow the description here: Look for the file 98vboxadd-xclient (e.g. /etc/X11/Xsession.d/98vboxadd-xclient) and comment out line 26 giving the warning as shown below:

if ! test -c /dev/vboxguest 2>/dev/null; then
   # Do not start if the kernel module is not present.
   # notify-send "VBoxClient: the VirtualBox kernel service is not running.  Exiting."

(Works on Ubuntu 16.04.)

| improve this answer | |
  • On my 14.04 machine the if block is followed by an elif block. If I comment out line 26, which is everything that's contained in the if block, this will be seen as a syntax error and I can't log in any longer. Quick fix: add a meaningless line of code instead of the one commented out (e.g. echo woof > /dev/null) – panepeter Nov 2 '17 at 8:58
1

Pay attention to the purge command which deletes configuration files

sudo apt-get purge virtualbox-guest-x11 virtualbox-guest-utils virtualbox-guest-dkms

I've found it here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.