9

I've been using the Linksys USB6300 Adapter but when I switched to Ubuntu it stopped working since its only compatible with Windows. I've tried using ndiswrapper and although it says my windows driver is installed, my device isn't showing up. Anyone know how I could get this wireless network adapter working? Thanks.

lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 012: ID 05c6:6766 Qualcomm, Inc. 
Bus 001 Device 006: ID 0bda:0153 Realtek Semiconductor Corp. Mass Storage Device
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 004: ID 04ca:007d Lite-On Technology Corp. 
Bus 001 Device 003: ID 04ca:008a Lite-On Technology Corp. 
Bus 001 Device 010: ID 13b1:003f Linksys 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
2
  • Please edit your question and add output of lsusb terminal command.
    – Pilot6
    Jun 30, 2015 at 15:50
  • There is no need to add [Solved] in the title here btw
    – Tim
    Jun 30, 2015 at 16:42

1 Answer 1

10

You need to install a driver for this dongle. Connect to internet another way and run in a terminal

sudo apt-get install git dkms
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux
cd rtl8812AU_8821AU_linux
make
sudo make install

Then reboot, insert the dongle and test. If there are any errors while running comands, then post them to your question.

To set it up permanently run these commands

cd ~/rtl8812AU_8821AU_linux
sudo make uninstall
make clean
sudo cp -R ~/rtl8812AU_8821AU_linux /usr/src/rtl8812AU_8821AU_linux-1.0
sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0

The driver will be installed using DKMS.

If the driver is installed first time the commands are

sudo apt-get install git dkms
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux
sudo cp -R rtl8812AU_8821AU_linux /usr/src/rtl8812AU_8821AU_linux-1.0
sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0
7
  • there were a few warning messages but it had no errors ex /home/pirates19/rtl8812AU_8821AU_linux/os_dep/linux/rtw_android.c:596:20: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast] if (copy_to_user((void *)priv_cmd.buf, command, bytes_written)) { ^ forgive my horrible ability to format my comments and posts
    – Pirates19
    Jun 30, 2015 at 16:31
  • Warnings are OK. @Pirates19 And additional information should be added to your question not to comments.
    – Pilot6
    Jun 30, 2015 at 16:33
  • Idk what you did but it worked great thank you so much!
    – Pirates19
    Jun 30, 2015 at 16:39
  • @Pirates19 I updated my answer with directions how to install it permanently. Otherwise the driver will not survive kernel upgrades.
    – Pilot6
    Jun 30, 2015 at 16:44
  • I'm running Ubuntu 15.10 654 bit and I my system does not have "dkms" executable. I tried as root, tried to find how to install it - no dice. Please help. Mar 24, 2016 at 2:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.