1

I download given package of teamviewer for Ubuntu from there official website and download both links. 1.teamviewer_amd64.deb(Here error shows not installed i386)
2.teamviewer_i386.deb (According to their site this is actually what i need).

So when i install (2.) through ubuntu software centre I got error shows

Selecting previously unselected package teamviewer:i386.

(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%   
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 163057 files and directories currently installed.)
Unpacking teamviewer:i386 (from .../Desktop/teamviewer_i386.deb) ...
dpkg: dependency problems prevent configuration of teamviewer:i386:
teamviewer:i386 depends on libfontconfig1.
dpkg: error processing teamviewer:i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
teamviewer:i386

Therefore, I run command sudo apt-get install -f and then execute command sudo apt-get install libfontconfig1 and by doing this i got this

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libfontconfig1 is already the newest version.
The following packages were automatically installed and are no longer  required:
mingw-w64 sbsigntool libxfixes3:i386 gir1.2-timezonemap-1.0 realpath
efibootmgr diffstat libdmraid1.0.0.rc16 libdebconfclient0
binutils-mingw-w64-i686 kpartx-boot libopts25 gir1.2-json-1.0 quilt   autogen
libfreetype6:i386 gcc-mingw-w64 user-setup libexpat1:i386 gcc-mingw-w64-i686
kpartx rdate libxcb1:i386 libxau6:i386 binutils-mingw-w64-x86-64
libxinerama1:i386 libdebian-installer4 libopts25-dev libice6:i386
libxdmcp6:i386 btrfs-tools apt-clone localechooser-data libasound2:i386
gcc-mingw-w64-base libxrender1:i386 libjpeg62:i386 libxtst6:i386
gcc-mingw-w64-x86-64 libx11-6:i386 libsm6:i386 archdetect-deb
libxdamage1:i386 dmraid python-pyicu mingw-w64-dev libxext6:i386
libxrandr2:i386 gir1.2-xkl-1.0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 534 not upgraded.

I than again install that teamviewer_i386.deb and i am again getting same error about libfontconfig1 not install that i pasted earlier.

Please help whats going on. Even i also tried installing language packages but its not working. Even if when i tried to install like synaptic package installer it shows first remove teamviewer_i386.deb package.

So how to i Install teamviewer in Ubuntu 12.04 64bit.

Thankyou in advance...

1

So how to i Install teamviewer in ubuntu 12.04 64bit.

So your system is 64 bit.

So when i install (2.) through ubuntu software centre I got error shows

So you are installing the 32 bit version?!

Why you are doing that, since you have 64 bit package why you are going to to install the 32bit package.

Anyway

teamviewer:i386 depends on libfontconfig1.

Then you should install libfontconfig1:i386 and not just libfontconfig1, but this may put you in some dependencies hell.

So I advise you to download the 64 bit again and install it instead to get rid of those possible problems.

Quoted from: How do I install TeamViewer on my Linux distribution?

For 64-bit DEB-systems without Multiarch you need the teamviewer_amd64.deb package.

For the 64-bit package:

sudo dpkg -i teamviewer_linux_x64.deb

In case “dpkg” indicates missing dependencies, complete the installation by executing the following command:

sudo apt-get install -f
0

As I had posted elsewhere.

You could try doing this sudo apt-get purge team-viewer-package-name and sudo apt-get purge libfontconfig1 ,then install libfontconfig1 and then Teamviewer.

Purge - Purge is identical to remove except that packages are removed and purged. Purge meaning that any configuration files are deleted too.

Also try this and see which all directories have teamviewer installed in them dpkg -L team-viewer-package-name and dpkg -L libfontconfig1.

Make sure you have run this after installing libfontconfig1 sudo apt-get update and sudo apt-get upgrade.

Let me know if this works or not.

0

Type these commands after you get the error message

dpkg --add-architecture i386
apt-get update

It is stated in the teamviewer documentation that there is possibility of wrong architecture error while installing x86 package on 64 bit. This should solve the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.