-1

Ubuntu 15.04 GCC 5.1.1


After installing ubuntu 15.04 vmware is no longer working with gcc 5.1.1

While trying to launch vmware workstation I get an error.

Tried to push refresh, nothing happens... also tried to add this path

/usr/lib/gcc/

and any sub-path but it didn't work.

closed as off-topic by Zanna, Yaron, user117103, Kevin Bowen, Eric Carvalho Aug 11 '17 at 12:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Zanna, Yaron, guntbert, Kevin Bowen, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

0

I did it by downgrading GCC in my Ubuntu here it is .. 1 - Uninstall GCC 5.1.1 :

sudo apt-get remove gcc-5
sudo apt-get remove --auto-remove gcc-5
sudo apt-get purge gcc-5

2 - install gcc 4.9.2

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install g++-4.9

3 - make a link to your gcc 4.9.2

ln -s /usr/bin/gcc-4.9 /usr/bin/gcc
ln -s /usr/bin/g++-4.9 /usr/bin/g++

4 - open VMware and it will run perfectly ;)

0

Compile manually..

cd /usr/lib/vmware/modules/source
sudo tar -xvf vmnet.tar
cd vmnet-only
sudo make
cd ..
sudo tar -xvf vmmon.tar
cd vmmon-only
sudo make
cd ..
sudo mkdir /lib/modules/$(uname -r)/misc/
sudo cp vmmon.o /lib/modules/$(uname -r)/misc/vmmon.ko
sudo cp vmnet.o /lib/modules/$(uname -r)/misc/vmnet.ko
sudo depmod -a
sudo /etc/init.d/vmware restart

Not the answer you're looking for? Browse other questions tagged or ask your own question.