0

I am using Ubuntu 14.04 LTS and have recently installed a new TP-LINK TL-WR841N Wireless N router at my home. Since then websites such as Facebook, Yahoo, Stackoverflow itself are not properly opening. The browser is not able to access the images, CSS/JS files for these websites. It is same for all Firefox, Chrome, Chromium Browser. The developer console gives CORS(Cross-origin resource sharing) errors when accessing these websites over wifi. Instead when i use my mobile phone as hot-spot and access these sites using my mobile data everything is working as it should. Also there is no problem in accessing wifi through this router when using Windows 7 or 8.

I have already tried the following to no good effect :

  • Restarting the system
  • Restarting the Router
  • Restarting Network Adapter
  • Updating the system
1

After searching on a lot of sites and blogs, apparently using an open DNS such as 8.8.8.8 or 8.8.4.4 rather than using automatic DNS solved the problem. I still don't know why the automatic DNS for the router is not working for Ubuntu although it is working fine for Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.