Ubuntu 14.04. I installed SunPinyin and it worked good. But under language bar, there are three choices: Eng, Pi (Pinyin), Sunpinyin. I wanted to remove Pi (Pinyin)(which does not work). Tried remove, purge ibus pinyin command and Pi (Pinyin) is still there. Text entry only showed two choices: English and Chinese (SunPinyin). Help!

4 Answers 4


You can try finding out what other pinyin libraries are installed using:

$ dpkg --get-selections | grep pinyin
ibus-sunpinyin                  install
libpinyin4:amd64                deinstall
libsunpinyin3:amd64             install
sunpinyin-data                  install

and then remove it using apt-get remove or aptitude remove

$ sudo apt-get remove ibus-libpinyin


I had the issue too and this solved by following Shiheng Zhang instruction. Just to extend what he suggested.

Reinstall ibus-pinyin

sudo apt-get install ibus-pinyin
ibus restart

Then, right click on the language icon and choose 'Text entry settings...' Then, remove 'Chinese (Pinyin)' from the input source and you're done.


I tried to remove Pi too but failed. I reinstalled ibus-pinyin and deselected Chinese(pinyin), that Pi disappeared.

  • 2
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Aug 17, 2015 at 10:05

Some times, the problem is that the IBus daemon is not running, so when you open the 'Text entry settings...' dialog, you don't see the "Chinese(pinyin)" entry there. What I do is follow this method by first start the ibus daemon:


Which just start the ibus daemon, after that, you can see the "Chinese(pinyin)" entry is shown in the dialog(suppose you have ibus-pinyin already installed), now, you can click the "-" key to remove this entry.

After that, you can stop the ibus daemon(kill the process), and this time, the "Pi" icon is disappeared.

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.