I have a Lubuntu machine which I use as my main home file backup.

I have a Wordpress blog which I would like to backup using a plugin. The plugin allows backup to FTP/SFTP, so this seems the best option.

I already have OpenSSH server running on my Lubuntu machine, and have connected to it from within my home network from another machine.

However, I keep getting errors when I try to backup from my Wordpress blog to my Lubuntu machine. I believe now that this is because I was using my home network IP for the FTP Server (i.e. 192.xxx.xx.xx), and of course a utility on the public Web couldn't understand this IP.

How would I go about connecting to my Lubuntu machine via SFTP from outside my home network?

PS I thought it was because of ufw for a while, but my SSH port is allowed through ufw.

Thanks for your help.

  • 1
    Can you at least SSH in into your server? As for connectivity, you need to use the external IP address of your router, and make sure that port 22 is open on your router and is forwarding it to your server. Jun 29 '15 at 16:57
  • Yes I can SSH in from another machine on the local network. Can I find the external address on the router admin page in-browser? I'll check re. port forwarding, I haven't done it before but there's a first time for everything. I'll update here for posterity. Jun 29 '15 at 19:50
  • You should be able to find it there. Alternatively, see this question. Jun 29 '15 at 20:49
  • So, I found out my external IP address using Portforward.com, and then set up port forwarding on SSH (22) as described above. However, the FTP connect from the Wordpress plugin STILL fails. I'm not sure if this is some problem with it internally, or if I made a mistake. I was presented an option (when setting up port forwarding in my router admin) to do it for IPv6 or IPv4. Do I need to do it for both? Jun 30 '15 at 6:41
  • FTP has no relation to SSH, and runs on port 21. SFTP, which has little to do with FTP and uses SSH, runs on port 22. Jun 30 '15 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.