I installed unity 7 using

bzr lp:unity trunk

and I wanted to try a small hack to get started what I did is that I just modified the sentence that appears in the search box when you open the launcher and I did make and then sudo make install to install the new unity binary in ~/staging/bin then I run unity --replace & to test if the change was applied but since then I am unable to login to my system using my standard user account it gives me System Program Problem please could somebody help me with this?, if I cannot login I will need to reinstall my system. Thanks in advance.


I managed to solve the problem. In my home directory I found .compiz and .compiz-1 directories I renamed the first one to compiz-old and the second one to .compiz so ubuntu now uses the second one for unity and this solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.