13
Error: "http://localhost/phpmyadmin/index.php"  

Cannot connect: invalid settings.   
Connection for controluser as defined in your configuration failed.

I was using LAMPP with mysql password as root. Then I installed xampp on Ubuntu 15.04. After that I'm unable to access my phpmyadmin page.

I tried changing config file removing cookies but still the same error.

1
  • sudo dpkg-reconfigure phpmyadmin – Maythux Jun 29 '15 at 8:15
31

run the command:

sudo dpkg-reconfigure phpmyadmin

You need to reconfigure it because lamp and xampp run phpmyadmin in different ports. So, it is probably a port conflict. You can also open server.xml in your lampp and change the port no. which would be different from that of xampp. Then both MySQL (of xampp and lamp as well) will run.

3
  • thnx... I tried localhost:81/phpmyadmin it worked!! – Mash S Jun 29 '15 at 8:57
  • 2
    thanks! turns out when the gui screen comes asking between apache and lightppd, we're supposed to press space to select apache - even though its highlighted, it's not selected. This commands brings up that screen again so we can configure properly in case we missed it out the last time. one proper tutorial warning about this : digitalocean.com/community/tutorials/… – Nikhil VJ Feb 10 '20 at 6:37
  • It's so easy to miss that lame ncurses spacebar-to-check-apache step! I did the same thing, and this also fixed it for me, thank you all. – moodboom Feb 1 at 19:33
1

Just run the command:

sudo dpkg-reconfigure phpmyadmin

enter image description here

1
  • 2
    Weird, just use it. I have the prompt for the Apache settings but not this screen to reinstall the database. – COil Nov 9 '18 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.