0

Something happened to my laptop recently and whenever I booted it up, it freezes and my cap locks button blinks. I did a little googling on this and it appears that it is caused due to a kernel panic. This might have been caused by me removing my SD card while it was formatting.

My question is this: I have downloaded a new Ubuntu image and booted to my USB and I am trying to save some of the files on my laptop before I reformat it since I can't seem to fix the kernel panic. When I boot in the USB and go to "Try It", I am able to load up my HD. (I have encrypted the HD and encrypted my Home Folder). I enter the password to mount the HD but I am unable to access the home folder. Is this because of when I encrypted the home folder as well? If so, I do not get a prompt to enter the password. How would I be able to access the home folder? Thanks!

1

It sounds like you're using dm-crypt/cryptsetup/LUKS on your whole partition, and also eCryptFS for your old home folder. Since you can already decrypt the whole partition ok, you just need to decrypt your home folder now.

Easiest is probably using the ecryptfs-recover-private script, just run it (optionally telling it where your encrypted private directory is) and it should take care of the rest.

See these for more info:

  • I ran the script and it worked. I got a "Success! Private data mounted at [/tmp/encryptfs...] But when I try to access the folder it denies me because I do not have the necessary permissions to view the folder. Then I opened up nautilus and opened up the folder but inside the folder there is just a file called "Access-Your-Private-Data.desktop" and a README.txt. Upon reading the txt file, it tells me to click on the .desktop file or run the command you stated above. I clicked on the .desktop file and nothing happens. – NuWin Jun 30 '15 at 5:28
  • hmmm... if it did work right when it said "Success! ... mounted at /tmp/ecryptfs...." then it might only take sudo / root permissions to view your files. Using sudo ls /tmp/ecryptfs... should let you see them in a terminal, or running your file manager as root / with sudo should work too. I think running sudo nautilus should do it. – Xen2050 Jul 1 '15 at 10:53
  • I've tried everything you said.. sudo ls /tmp/ecryptfs... only reveals Access-Your-Private-Data.desktop & README.txt I guess the only way is to open up the .desktop file... however when I sudo nautilus into the folder clicking it does nothing. – NuWin Jul 3 '15 at 4:49
  • What if I just install another Ubuntu partition side by side, would I still be able to access the previous partition on the new installation? I am getting a little desperate because I do not want to lose files but I just might be able to live without them.. – NuWin Jul 3 '15 at 19:18
  • The results of your ecryptfs-recover-private command are strange, it's as if the always-visible "fake" home folder contents were encrypted by eCryptFS... maybe it was set up strangely. But, maybe there's other encrypted home folders, you can tell ecryptfs-recover-private to try decrypting a specific folder, maybe it's not getting the right one. I don't know what else to try... maybe try Disk Usage Analyzer (baobab) and see if the actual home folder is somewhere else (guessing from it's size)? – Xen2050 Jul 7 '15 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.