2

I'm running Ubuntu 14.04 on a laptop with an nVidia 850m. I installed proprietary drivers and bumblebee and everything worked fine for weeks. After running a dist-upgrade I have a black screen on boot. I tried reconfiguring Xorg but I receive an error message

Missing output drivers. Configuration failed.

What could I do?

2
  • That's because you didn't install dkms before installing the nvidia driver and so you now have to reinstall nvidia driver because you did a dist-upgrade. Install dkms before reinstalling nvidia to prevent this from happening in the future.
    – mchid
    Jun 28, 2015 at 17:32
  • Btw are using 32 bit or 64 bit linux?
    – TellMeWhy
    Jun 28, 2015 at 19:02

2 Answers 2

2

Remove everything to do with the Nvidia proprietary drivers:

sudo bash NVIDIA-Linux-x86_64-352.21.run --uninstal

Remove xserver settings:

sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstall the above (not proprietary):

sudo apt-get install nvidia-common
sudo apt-get install xserver-xorg-video-nouveau
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure xserver:

sudo dpkg-reconfigure xserver-xorg
7
  • 1
    Nvidia proprietary drivers = NVIDIA-Linux-x86_64-352.21.run in the current incarnation, you UNINSTALL it with sudo bash NVIDIA-Linux-x86_64-352.21.run --uninstall. Even if installed it will not be visible in dpkg --list
    – Hannu
    Jun 28, 2015 at 18:32
  • Thank you! Since I'm using the proprietary drivers, should I replace your install nvidia-common with my installation?
    – Alessandro
    Jun 28, 2015 at 18:52
  • @Alessandro Yes, if it works for you.
    – TellMeWhy
    Jun 28, 2015 at 19:01
  • 1
    As for now, I solved following your steps, I'll maybe try with the proprietary drivers tomorrow after my project presentation not to risk breaking the system again ahah thank you so much! Do you know how I could prevent this from happening next time I perform a dist-upgrade?
    – Alessandro
    Jun 28, 2015 at 19:05
  • Do mention though the command sudo dpkg-reconfigure xserver-xorg will not and should not work if it's complete 14.04.2 that is point release 2 whereas the package is xserver-xorg-lts-utopic version 1:7.7+7ubuntu2~trusty1 and standard 14.04.1 is 1:7.7+1ubuntu8.1 and the command for installing video for example xserver-xorg-video-all-lts-utopic
    – JoKeR
    Jun 29, 2015 at 12:48
1

If you don't have dkms installed, and you do a dist-upgrade, you MUST to reinstall the proprietary nvidia driver.

First, install dkms so that this does not happen again in the future:

sudo apt-get install dkms

Now, reinstall the nvidia driver and next time you do a dist-upgrade, the driver will install itself for you.


You should be able to boot from the old kernel. Choose advanced options from the grub menu and then select the older kernel from the next menu.

4
  • For what it is worth, dkms is NOT a guarantee that it won't happen again - depending on the updates at hand. Things related to new Kernels and X are the common factor in this (One year experience with ASUS GTX 780 and all possible drivers)
    – Hannu
    Jun 28, 2015 at 18:33
  • It seems I already have dkms! I'll try reinstalling the drivers anyway, thanks
    – Alessandro
    Jun 28, 2015 at 18:49
  • @Hannu nothing is a guarantee, "to the fullest extent of the law"
    – mchid
    Jun 28, 2015 at 19:37
  • @Alessandro also, dkms must be installed at the time the nvidia module is compiled.
    – mchid
    Jun 28, 2015 at 19:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.