0

I've set up a VPN using the guide here but what I cannot seem to get working is forwarding all my internet traffic over the VPN. I can connect and view the other machines on my network.

I am using UFW to set the firewall settings. I have opened 22, 1723, 80 so far.

Output of route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
REMOTEIP  0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.0.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

Any suggestions?

  • Please edit your question and add output of route -n terminal command. – Pilot6 Jun 28 '15 at 10:14
0

If you want to redirect all traffic to VPN, then do

 sudo route del default
 sudo route add default dev ppp0

You can also set it up in ppp config by adding option replacedefaultroute

  • That broke it, when I entered that it said: SIOCDELRT: No such process – Josh Jun 29 '15 at 10:42
  • @Josh Anyway you need to set defaultroute to ppp0. – Pilot6 Jun 29 '15 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.