0

I'm using Ubuntu 14.04 with AMD proprietary drivers. I want to replace the proprietary driver with open source because it is freezing during debugging of multi-threaded program.

I'm uninstalling the proprietary driver using aticonfig --uninstall. Now Ubuntu switches back to open source drive but everything is slow after that.

My machine is also heating too much and it's getting thermal shutdown in a couple of minutes. I do remember installing some packages which resolved this issue but I forgot the name of the packages. I did that last year where I accidentally uninstalled a package. Live CD does not show this over heating and slowing issue.

EDIT

After installing opensource drive lsmod | grep radeon returns nothing. Which simply means that the radeon module is not loading at startup.

$ lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7640G]
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]
1

/var/log/Xorg.0.log showed me that I was missing libGL.so.1. So I installed libgl1-mesa-glx. I also loaded the radeon module as suggested here and also blacklisted fglrx (this was important in my case as Xorg.0.log keeps on saying unable to load fglrx; actually it's still saying that but everything is working fine.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.