I recently installed linux on a macbook air (early 2014) and am trying to tweak the touchpad so that its actually usable.

I have noticed the following:

1) I frequently get accidental right click menus that pop up randomly while surfing the web. It seems the touchpad is very sensitive and I want this to stop.

2) I can move the cursor around with 1 finger moving around the touch pad but as soon as I place another finger or part of my hand (often by accident) on the touch pad all navigation stops and I cannot move the cursor so long as more than one piece of flesh is touching the touchpad. I do not want this to happen and don't know how to prevent this. MacOS is not as restrictive like this.

To address #1, I tried the suggestion at the link below, which attempts to change the default right-click mechanism to that of MacOS which is a button+click.

https://www.void.gr/kargig/blog/2009/06/11/handling-right-clicks-on-a-macbook-running-linux/

However, that did not work. When I click on the COMMAND key the Linux Mint menu pops up instead. The right-click functionality is unchanged and remains the 2 finger tap.

I also placed the following in /etc/X11/xorg.conf.d/50-synaptics.conf:

Option "TapButton2" "0"

Like so:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
       MatchDevicePath "/dev/input/event*"
       Option "TapButton2" "0"
EndSection

However, that did not do anything and when I run synclient -l I still see:

TapButton1              = 1
TapButton2              = 3
TapButton3              = 2

I also checked the /var/log/Xorg.0.log and I do see that the TapButton2 =0 got picked up but it hasnt taken effect because I can still right click by clicking the touchpad with 2 fingers.

[     9.240] (**) Option "TapButton2" "0"

At this point I'm not sure whether its even possible to properly configure the touch pad as it seems simple configuration changes don't work.

I had similar problems on MacBook Pro (8,1) with Ubuntu 15.04 (and on earlier releases). For a short term fix try using synclient directly, e.g., synclient TapButton2=0. I made my changes permanent by copying /etc/X11/xorg.conf.d/50-synaptics.conf to /etc/X11/xorg.conf.d/10-synaptics.conf (I don't think you are supposed to edit the former). At the bottom of the new file, include a new section

    Section "InputClass"
            Identifier "Set TB2 to 0"
            MatchDevicePath "/dev/input/event*"
            Option "TapButton2" "0"
    EndSection

You may need to reboot. Finally, for my edits, instead of MatchDevicePath I copied the MatchProduct and MatchDriver information from a previous section in the file (not sure if this is necessary). Finally*2, tweaking the sensitivity (with FingerHigh or FingerLow) may help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.