4

I am trying to set the SNMP authentication protocol to SHA to connect to my CISCO switch. When I run:

sudo munin-node-configure --snmp SWITCH01 --snmpversion 3 --snmpauthprotocol sha --snmpusername munin --snmpauthpass PASSWORD

I am getting the error:

Unknown option: snmpauthprotocol

It does say in the manual that the option is available:

--snmpauthprotocol <protocol>
           Authentication protocol.  One of 'md5' or 'sha' (HMAC-MD5-96, RFC1321 and SHA-1/HMAC-SHA-96, NIST FIPS PIB 180, RFC2264).  ['md5']

I could change the protocol on the switch ... If I hadn't accidentally denied ssh access for myself ... I don't feel like taking a 2 hour drive today :/

Just as an extra note, if I run it without the --snmpauthprotocol and with --debug I get:

Received usmStatsWrongDigests.0 Report-PDU with value 4 during synchronization

So, I definitely can't use md5 ...

3
+100

I just downloaded munin 2.0.25 and looked at the source. Try using --snmpauthproto instead of --snmpauthprotocol.

Yes, the help text is wrong. I'll probably open an issue here: https://github.com/munin-monitoring/munin/issues. I have put in a pull request to correct the typo in the code https://github.com/munin-monitoring/munin/pull/510 which has now been encorportated into the github code and may be included in release 2.1.13 .

  • You're right :D ... Unfortunately it's still not working for me ... I decided to have a delve into the source as well (Even though I've never used Perl, so it was an experience) ... I was trying to ensure sha was being passed correctly, and not always defaulting to md5 ... That bit is working correctly, so it's now something I have to fix on my switch Lol ... Also it took me a while to track down how the --snmpauthproto switch is being passed to NET::SNMP, because the reference name changes about 20 times, from snmpauthproto to snmp3authproto, authproto, authprotocol etc ... – Just Lucky Really Jul 2 '15 at 15:51
  • Maybe that's something that could be looked at too :D – Just Lucky Really Jul 2 '15 at 15:51
  • If you need to delve into Perl source in the future for stuff like this, I can recommend this cool debugger called Devel::Trepan – rocky Jul 2 '15 at 23:18
  • Nice, might take a look when I start learning Perl lol ... Is that your creation? – Just Lucky Really Jul 2 '15 at 23:26
0

Have you tried this:

  sudo munin-node-configure --snmp SWITCH01 --snmpversion 3 --snmpauthproto md5 --snmpusername munin --snmpauthpass PASSWORD

and it might work fine this way.

  • Nope, --snmpauthproto sha256 doesn't work ... I tried --snmpauthproto sha-I-Like-Cheese too, same result. – Just Lucky Really Jul 2 '15 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.