picture of error

Initially, the computer was showing the error as mentioned in How to fix "The system is running in low-graphics mode" error? question. Fixing it resulted in the above error.

Please take look at the last line

Started GNOME display manager... and deal with any system changes..p link was shut down.....

One more thing before all this problem I have edited xorg.conf file to use Tooya X graphic tablet as suggested on here.

I don't know if that's the reason but I thought it is important to share.

  • I can see no error there. How long did you leave it for? – Tim Jun 28 '15 at 15:02
  • For about 2 hours. @Tim – Freddy Jun 28 '15 at 15:06
  • Hmm okay. It's strange because there is no obvious error. – Tim Jun 28 '15 at 15:07
  • 1
    Try pressing various combination of Ctrl+Alt+Fkey. Ubuntu gui is typically on F7, other F keys are virtual terminals. Also Alt+arrow left/right. I think 15.04 on my other laptop had similar issue – Sergiy Kolodyazhnyy Jun 30 '15 at 3:21
  • 1
    @Serg Ctrl + Alt + F 1-6 opens virtual terminal while Cltrl + Alt + F7 returns back to black screen shown in question. – Freddy Jun 30 '15 at 3:25

10 Answers 10

Alt+F2 keystroke which started the terminal session for me and I was able to login.

sudo apt purge gdm gdm3
sudo apt install gdm3 ubuntu-desktop

Then choose your display manager in the menu that opens (for Ubuntu 16.10+ the default is GDM, for 16.04 and earlier the default is LightDM), or use sudo dpkg-reconfigure gdm3 to choose GDM.

systemctl restart gdm

This should work

There appears to be other people having this issue as well. A bug report was also made on this. It appears to be a bug with version 3.16. A temporary fix would be to use LightDM instead, so (in a VT, eg Ctrl+Alt+F1:

sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm

Press enter to get past the "Configuring lightdm" screen, and then navigate to LightDM in the list of options and press Enter. Restart, and you should be using LightDM. This should work temporarily until the GDM bug is fixed.

  • 1
    Does not work :( – Freddy Jul 1 '15 at 3:22
  • 2
    Could you please be more specific as to what doesn't work? – nixpower Jul 1 '15 at 22:56
  • This worked for me. I also apt remove gdm3, although not sure if it was necessary. – DavidEG Dec 10 '17 at 7:58
  • Your solution worked for me thank you same my linux :) – ahmedbhs Apr 30 at 21:08
  • I'm using Dell latitude 5580 and had similar issue time to time, formatted few times but the issues comes. This one worked for me and this only. Thanks a lot for saving my time. – Kandy Oct 16 at 16:23
up vote 2 down vote accepted

I tried all the possible solutions mentioned in comment area and other answers. Unfortunately none of them work.

Solution that worked for me was format and re-install.

I had to format my laptop before re-installing. Because re-installing without format was not working. I mean computer starts normally but there were several bugs with WiFi, Bluetooth, USB, etc.

  • i happen to get this issue as well, did you get it again?.. i want to be really sure if it doesn't happen again in post-format and re-install, otherwise. it wouldn't be worth it – Oscar Reyes Mar 19 '16 at 21:26
  • @nosthertus It's like a year...till now all working fine. – Freddy Apr 4 '16 at 8:26

I solved this issue like this:

  1. Press CtrlAltF7
  2. Press AltF2
  3. Log in via terminal
  4. Go to /etc/X11 and delete xorg.conf (or rename for backup)

You will get more details when running gdm manually in a virtual console (Ctrl + Alt + F1):

sudo gdm

For me, the problem was that gdm wasn't able to find /usr/bin/X, which led me to this bug. Turns out xserver-xorg was not installed somehow. The following line solves this particular problem.

sudo apt-get update && sudo apt-get install xserver-xorg

Hope this helps.

I had the exact same issue, After messing around for 3-4 hours I finally got the ubuntu running.

Before I reboot the ubuntu I did install xubuntu by

sudo apt-get install xubuntu-desktop

and then I did

mkdir -p /var/lib/lightdm

chown -R lightdm:lightdm /var/lib/lightdm

chmod 0750 /var/lib/lightdm

So it installed xubuntu desktop but I got everything working fine.

This is how I did it.

I would suggest first try the 2nd part if that does not work then try the installing xubuntu desktop.

Hope it helps someone.

In my case with Ubuntu 17.10 in a Virtualbox VM the error occurred because the partition for Linux was full. I solved this problem this way:

  1. Start the machine with using Linux live image (on CD, USB or so)
  2. Mount the Linux partition and create space
  3. Restart the machine

Enter a TTY with Ctrl+Alt+F6 and run:

sudo apt-get install LXDE

Then execute

startx

and then push start button left corner and the preferencs and the upper gfx settings adm and set all to default, and reboot and it might work fine this way.

Happened with me with gdm 3.28. The problem was nvidia driver (which was working fine few days before) After allowing software updater to install updates I shut it down and rebooted in morning to see this same error.

Solution:

Uninstalled nvidia driver (I used the .run file to install it)

Press Alt+F3 to access console mode

sudo nvidia-uninstall
shutdown now

Verdict: Do not update software from GUI if you have nvidia driver installed. Check if the update will affect any installed driver, especially if the driver isn't from ubuntu repositories

Start Ubunto in recovery mode, (Esc->Advanced options->recovery mode). You have few things to check and correct, in particular my issue was solved after selecting and passing tow entries [dppk: repair broken packages], some upgrades where done and some obsolete packages removed. then i check entry: [grub: update grub bootloader] ... something was corrected! then i chose to boot ... then system boots normally! my point is if you can boot in recovery and check your fs ...etc. then no need to format/install.

protected by Community Dec 10 at 14:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.