0

I am new to Linux world so please do not be very harsh with me. I have VSphere in which I installed Centos7. Inside it, I want to install Ubuntu Trusty Thar using Virtual Manager. I created a virtual machine but when I want to open it I receive the following message:

Error connecting to graphical console: Error initializing USB support: Other errors[-99]

Why is this happening and how to fix it?

Thank you

0

I would comment but I don't have enough rep... TBH I don't think that this is an Ubuntu issue but one more to do with how you have KVM set up.

Also off on something of a tangent, unless you have pretty new Server grade hardware (with the right options enabled in your UEFI/BIOS and your host OS) nested visualization (i.e. virtualisation inside virtualisation) best case won't work well; worst case won't work at all.

Why not install Ubuntu to vSphere!? Or install a different hypervisor OS (one that you are happy to install VMs directly into)?

  • Thank you for your answer. Regarding your questions, this are my requirements so I can't change this. Also I think this issue is not related to Ubuntu but rather with the KVM setup or with the hypervisor or with both( i tried the same scenario on vmware-player and it worked). Still I can't find any valid KVM setup to try to compare between that and what I have. – florin Jun 29 '15 at 7:40
  • It seems like a strange setup and one that I would not recommend; but it sounds like you don't have any control over it so I guess you need to run with it. I personally use ProxmoxVE (which uses both KVM and OpenVZ) and haven't done nested virtualisation, nor used KVM on it's own so I'm not really any further help to you sorry... And seeing that the issues seems to be really with CentOS and/or KVM rather than Ubuntu; perhaps posting on their forums might be your best bet? Or perhaps even Ubuntu forums? – Jeremy Davis Jun 29 '15 at 8:12
0

I manage to resolve my issue: when installing a new VM, I changed the display setup from default to VNC server. I tried this with two OS and it worked ( ubuntu 14.04 and centos7.0)

  • So the question is how to get it working with the Spice display. – Pavel Šimerda Oct 1 '15 at 20:16
0

I added a usb controller to the virtual machine in vmware that I was using KVM and the console connected.

(Source)

Hope that helps, it worked for me in a similar setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.