2

My problem is similiar to: Blank desktop when logging in via xrdp But I am also loosing the connection.

I have an Ubuntu 14 Server VM in Microsoft Azure Cloud. And my laptop is Win8 X64.

I am able to access to the VM console via SSH by Putty.

I followed these instructions to make server accesible via mstsc (windows remote):

$ sudo apt-get install ubuntu-desktop 
$ sudo apt-get install xrdp

I set an end-point for port 3389.

I can make a remote connection and see the xrdp login window. I chose sesman-Xvnc Module and login with my credentials.

Then see this window: XRDP-loggin-details-window

And then an empty gray window with a cursor: enter image description here

After in a few seconds my connection is lost with no message or something. What could be the reason?

Any help would be appreciated.

3
  • I have this now too. Any luck? Did you ever fix it?
    – Mike Wise
    Commented Nov 20, 2015 at 11:05
  • No, I didn't try so much to solve it. But I know that there is a person who has solved. I asked him to help you. Maybe he answers here soon. Commented Nov 20, 2015 at 14:00
  • I tried it again a day later. And now I am not losing the connection as before, but it still just sits there and the Ubuntu Desktop (Unity?) never starts.
    – Mike Wise
    Commented Nov 20, 2015 at 14:51

1 Answer 1

0

possibly an old post but this might be helpful to other.

Unity Desktop is not supported by xRDP software package on Ubuntu You have to install an alternative desktop interface. A good alternative is the mate-desktop

You can install the mate-desktop using the following command

sudo apt-get install mate-core mate-desktop-environment mate-notification-daemon

Then you can install your xrdp package

sudo apt-get install xrdp

Note : On Azure, you will need to create the endpoint in order to access your Ubuntu VM using the xrdp software on the port 3389

There is post that will describe the process of installing xrdp on Ubuntu Server 16.04. Check this link for part I - Part II should be coming soon

Hope this is helpful

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .