17

I'm running Ubuntu 14.04 on an Acer Aspire 4750G laptop. Recently I've started having a problem with HTML SELECT option lists when using Chrome or Chromium.

Normally everything works fine, then the select options on web pages will start showing as blank. Here's a screenshot:

enter image description here

The problem occurs erratically and happens with both Chrome and Chromium, but not with Firefox. Once it happens I have to close all Chrome/Chromium sessions to get rid of it.

Once it occurs it happens on all sites but only seems to affect options. It's not a CSS error because the above sample was created with the most basic code possible:

<body>  
<table>  
    <tr>
        <td>Test Select:</td>
        <td>
            <select name="test">
                <option value="1">Option 1</option>
                <option value="2">Option 2</option>
                <option value="3">Option 3</option>
                <option value="4">Option 4</option>
                <option value="5">Option 5</option>
                <option value="6">Option 6</option>
                </select>
            </td>
        </tr>
</table>
</body>

If I look at the page source in the browser it looks fine, and I can select the options by cursoring up and down, but they don't display and I can't select with a mouse click.

Can anyone suggest why this may be happening? I've hunted Google but can't find a single reference to this problem. Would very much appreciate any suggestions.

Thanks Don

  • Hello! I have the same problem - did you perhaps find a solution for this? – daxur Jul 28 '15 at 6:26
  • 3
    @daxur - No solution yet although it seems to be a graphics driver problem. I am using an Acer Aspire 4750G with the dubious Optimus chip set. Have discovered that the problem occurs in browser windows displayed on an external HDMI monitor but if I drag that browser window to the internal laptop display it is fine. Dragging it back to the external display fails again. I'm running the default Nouveau drivers -- last time I tried installing the NVidia drivers I lost the system completely and had to reinstall to get it back so a bit paranoid about doing that again. – Don Dunlop Aug 4 '15 at 0:42
  • some co workers have the same problem. I think that not all of them have the same cpu/gpu. i know that not all of them have a dedicated gpu - the most have just an an 4th generation intel with an an Intel HD 4400 GPU. actually noone has the problem so i can't test if it works on the notebook monitor. – iRaS Sep 30 '15 at 11:55
  • Same thing here, trying to find a solution – Mathieu Dumoulin Oct 23 '15 at 16:32
  • Same here. @DonDunlop tip works for me too : issue occurs only on external monitor (wired through VGA cable though, not hdmi). On laptop display options get displayed as expected. – Mat Jan 13 '16 at 10:06
6

You have to turn off the hardware acceleration!

Check this out for the detailed solution -- I don't feel like copy pasting the whole thing and stealing someone else's answer!

http://www.solveyourtech.com/turn-hardware-acceleration-google-chrome/

The summary is that you need to go to 'settings' then 'advanced settings' in Chrome, then uncheck the hardware acceleration box.

  • Sorry... been off for a while and this is my first chance to test again. The problem I described occurred this morning so I turned off the hardware acceleration as per (excellent) instruction, and the problem immediately went away. However turning off hardware acceleration requires a restart of Chrome which usually fixes the problem by itself, so hard to tell whether this did it or not. I'll run it like this for a couple of weeks to make sure, but if the problem doesn't recur in that time then this would appear to do it. – Don Dunlop Nov 18 '15 at 3:03
  • this worked for me. I'm on Fedora 21 and Chrome 46 – Fernando Fabreti Nov 23 '15 at 18:45
  • Unfortunately this didn't solve the problem for me. Turning hardware acceleration off requires a Chrome restart and that temporarily fixed the problem, but it did recur. Having said that I have found a workable workaround. Restarting Chrome gets rid of the problem temporarily. Using chrome://restart will do this without losing content in your tabs. I just created an item on my bookmark bar called 'Reset' and pointed it to chrome://restart. When the problem occurs I click that, Chrome restarts and voila. Not very elegant but better than rebooting. – Don Dunlop Nov 26 '15 at 9:36
  • hehe, but Pragmatic Programmer states: “select” Isn’t Broken It is rare to find a bug in the OS or the compiler, or even a third-party product or library. The bug is most likely in the application. – isaias-b Jan 15 '16 at 13:18
0

Try to update to latest grapgics stack. https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Trusty

The 14.04.2 and newer point release will ship with an updated kernel and X stack by default. If you have installed with older media you can use the following to install the newer kernel from 15.04 (Vivid):

DESKTOP

 sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid 

MULTIARCH DESKTOP

If you run a multiarch desktop (for example, i386 and amd64 on amd64, for gaming or Wine), you may find you need a slightly more involved command, like this:

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libgl1-mesa-glx-lts-vivid libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid:i386
  • Thanks Yurii... I did try this and it seemed better at first but unfortunately the problem recurred. I do have a nice new kernel now, though. :-) As a workaround setting chrome://restart as a bookmark fixes the problem when it comes up. Ok for now. Thanks for the suggestion though. – Don Dunlop Nov 26 '15 at 9:40
  • None of these fixes work in 18.04.x ... – Kim Feb 11 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.