From what I understand, Transmission bittorrent client uses the miniupnp library to do it's UPnP port forwarding of routers, however on Ubuntu upnpc (a test client of the miniupnp library) doesn't find any IDG routers, while on another Windows machine on the same networks it works correctly (with the windows binary of upnpc).

From what testing I've done, it seems that the M-SEARCH SSDP packet is not being sent onto the network, perhaps a firewall or something is stopping it.

How do I try and make sure these packets get though and this works?


I just used upnp-router-control to add a port forwarding to my router and it worked like a charm :)

If that doesn't work for you i would suggest you use wireshark to analyze the network traffic and look where it hangs.

  • 1
    Just tried out upnp-router-control, the add/remove port mapping buttons are disabled for my router, although at least it does actually find it.
    – Adam M-W
    Oct 30 '11 at 12:35
  • Then how about the wireshark test to see if there is some firewall at work blocking packages?
    – flob
    Oct 31 '11 at 9:22

Run in a shell to add config lines after fresh installed miniupnpd

MiniUPnPd_LISTENING_IP=eth0.1" | sudo tee -a /etc/default/miniupnpd; sudo service miniupnpd restart

Note: eth0.4 and eth0.1 is my ext/int interfaces, use yours.

Check chains after UPNP aware program restart:

sudo iptables -vnL MINIUPNPD ;sudo iptables -t nat -vnL MINIUPNPD

Should show few rules

All tested on Ubuntu 13.10.

All files at /etc/miniupnpd/ just ignored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.