i have a toshiba satellite l15w-b1302. i followed various instructions for making linux work on my computer even though it came with windows 8.1. i wiped windows and installed ubuntu. when i power up, it doesn't see any bootable operating system. when i use boot repair, i get one shot. then something happens and it won't boot to anything unless i run boot repair again.

i've searched other threads for information, but boot up seems to be excessively technical with the help presuming knowlege i don't have. if anyone knows what the problem may be, can you help me through it presuming i know very little?


As someone else answered, disable secure boot... Also I would create a LiveUSB boot drive with either MBR/UEFI or GPT/UEFI with Rufus when building from an Ubuntu ISO.

When that's finished, press the Window Key on the keyboard (or click the window/start button), and type "recovery opt" and hit enter. Select Advanced Startup, the system will boot into a console, select 'Use a device' or 'boot to a device' and you should see your UEFI USB boot disk you just created if its plugged in... make sure you are using USB 3.0 port and not the USB 2.0 port and reboot to your UEFI thumb drive, and install Ubuntu. The Ubuntu install script will detect your are booting in UEFI mode and install Ubuntu/Grub boot loader as UEFI compatible. Legacy Bios mode on these Toshiba Satellite series (L15W) do not work very well at all.

When doing this, Windows will still want to be the primary bootloader, so you have to keep going into Win 10, then recovery console, and then booting from device, choosing Ubuntu, every time you want to use Ubuntu until you change the order in which boot loader is attempted to load first by Toshiba.

You can use this software to switch GRUB2 to be loaded before the Windows boot manager: http://www.easyuefi.com/index-us.html

But this is the least of your worries. These Toshiba series (L15W) have hard freezes in Linux at seemingly random times (all distro's I have installed have the same issue, either debian based or rpm based, so it most likely is a kernel issue with how it deals with the Toshiba-wmi and Toshiba_ACPI kernel modules in Linux). I posted a temporary work around in a few posts today, hoping others who own these same series of Toshiba laptops will report the bug as well when (not if) they run into it.

(I have had 3 replacements with the vendor so far because of this issue, and they all have had this issue, I can't seem to find anyone out there that can get this laptop to work in Linux without hard freezes/lockups, without setting up CPU thermal triggers to lower the CPU frequency.. (Linux cannot turn on the chassis fan inside, let alone even find it. Works fine in Windows 10 though).

| improve this answer | |

I own a Toshiba Satellite L15W-B1302 currently running Ubuntu 15.04, using Gnome. I had a lot of issues installing Ubuntu on my laptop until I found that I needed to uncheck secure boot in BIOS. Before I did this, the only time it would boot was from the liveUSB I was using to install. At first I tried to dual boot and figured this might be the issue, then I wiped windows 8.1 completely (after saving the recovery disk on another thumb drive). That's when I found a thread (I didn't save it as I as using the live version at the time) that told me to turn off secure boot. Hope this helps.

| improve this answer | |
  • Very long winded way to say "turn off secure boot". – guntbert Jul 1 '15 at 17:06
  • Us newbies need lots of information about stuff. A lot of replies I see from others who "know more" generally think the person asking questions knows all the things about linux, except what they are asking. I was in the same boat as he, doing the same things, so added extraneous information that might answer future questions. That is all. – Ryan Jul 2 '15 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.