1

I have this error message after running "sudo apt-get squid3 install" in terminal on ubuntu 12.04

The following packages have unmet dependencies:
 squid3 : 

Depends: squid3-common (= 3.1.19-1ubuntu3.12.04.3) but it is not going to be installed
1
  • Typically these problems can be solved by reading carefully the output of sudo aptitude install squid3 and looking at a few different solutions (respond n) – Brandon Bertelsen Jun 26 '15 at 8:15
0

Problem solved... I had to download the "squid-langpack" using my browser and installed it on the ubuntu after which the "sudo apt-get install squid-common" and "sudo apt-get install squid3"

-1

Is this all. If so then try installing the squid3-common package manually using

apt-get install squid3-common

and then try installing squid again.

3
  • Yeah I saw this somewhere online...I would do that and provide appropriate response if it works – quadriola Jun 25 '15 at 19:55
  • he following packages have unmet dependencies: squid3-common : Depends: squid-langpack (>= 20110214-1) but it is not installable E: Unable to correct problems, you have held broken packages. ubabf@BFKAPROXYSRV:~$ sudo apt-get install squid-langpack Reading package lists... Done Building dependency tree Reading state information... Done Package squid-langpack is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source – quadriola Jun 25 '15 at 20:32
  • This is because the package squid-langpack isnt available. It would be solved once you install it manually which you did. – sajinmp Jun 26 '15 at 10:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.