I use Ubuntu 10.04LTS from the beginning, and throughout that time the only thing that could not succeed was that this webcam is recognized but not working:

Bus 005 Device 002: ID 0c45:60fc Microdia PC Camera with Mic (SN9C105)

I use Ubuntu 10.04LTS 32bits and the kernel is 2.6.32-32-generic-pae. As I've been reading recently, which could for the kernel, a new search and I did not find any documentation that satisfactory.

In http://mxhaard.free.fr/spca5xx.html - appears as the webcam support Test and driver: spca5xx/LE - just bought this webcam to work on Linux, taking the version 9.04 on all other it worked, but now 10.04LTS repeats in the case of Ubuntu 9.04.

  • Unplug your webcam - run dmesg - plug into your webcam - rerun dmesg - the new output you see, please add that into your question.
    – fossfreedom
    Oct 3, 2011 at 13:59
  • Are you sure it's not working? Have you tried opening the device in VLC for example?
    – scottl
    Dec 1, 2011 at 4:31
  • What is the output of lsmod | grep videodev? Dec 7, 2011 at 21:31

1 Answer 1


I have found this page with a generic driver for this webcam's chip, I know its old but its worth giving a shot.

The problem with Microdia cams is really drivers, there is a huge list of user asking for them and trying to make them work and a very small list of users that actually made these work without problems.

The page you refer to is mostly provided for Creative Live! cams and none of those packages supports your cam.

Your device id (0c45:60fc) also does not show on the Ubuntu supported hardware list so it will be unlikely that you will this one working flawless anytime soon.

For a list of supported webcams in Ubuntu please have a look on this list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.