0

When I'm using my laptops built-in mobile broadband modem, skype cannot connect.

Additional symptom: After signing out of skype, I cannot sign in again. (Sign in works fine on wifi)

Everything else (internet connection from browser, dropbox, etc.) connects without problems.

Details:

  • Ubuntu 14.04
  • Thinkpad T440
  • Modem: Sierra Wireless EM7345 4G LTE

When using wifi, skype connects fine.

When using the same sim-card, inserted into a mobile wifi box like huawei E5776, skype can also connect without problems. (This is via wifi to the huawei box, and via gsm from there).

This indicates:

a) that it is not my ISP blocking anything. (also, according to their technical support they are not blocking).

b) that the problem is related to the use of the modem connection from ubuntu. It could be a problem with the modem (firmware?), or with ubuntu/modemmanager/networkmanager.

I suspect this has something to do with ubuntu and/or skype treating the wireless broadband connection differently from a wifi connection. Perhaps it has something to do with dialout, with 'metered connection', etc.

I checked the permissions on the modem device, only root had access to the device. The device did not have the dialout group, as described in this bug: https://bugs.launchpad.net/ubuntu/+source/udev/+bug/1032865

I added the device to the dialout group as described in the bug. After the fix:

crw-rw---- 1 root dialout 180, 0 Aug 26 11:09 cdc-wdm0

I also added my own user (the user running skype) to the dialout group, as described here: Changing permissions on serial port

BUT this did not solve the problem.

Any hints?

  • When I put the same sim card in a mobile wifi box like huawei E5776 skype can connect without problems. So i strongly suspect this is ubuntu blocking some connections when on a mobile broadband (wwan) connection, and not when on wifi. – sunew Aug 18 '15 at 21:31
  • Ping is your friend here :-). Can you ping the router when it doesn't connect to the internet? – o-0 Aug 18 '15 at 21:49
  • Dear dave - please read the question before commenting. There is no problem with connecting to the internet in general. – sunew Aug 19 '15 at 7:27
1

I found a blog that say that the stock drivers on your modem (Sierra Wireless EM7345 4G LTE) has some bugs in it, please read this link.

Also, did you try connecting Skype using a HTTP Proxy? Check the following link and give it a try...

0

I also use the Sierra Wireless, the only time I had this issue was when bandwidth was poor over 4G and it was actually more like 2G. Have you run a speed test when this happens? Also try disabling all other adapters then connect via 4G Network.

  • it is not related to bandwith problems. Internet connectivity works fine. – sunew Aug 24 '15 at 8:42
0

A workaround for getting acces to using skype when on my mobile broadband connection:

Use the skype web client, https://web.skype.com/. Unfortunately video / voice calls do not work (yet) on linux - only text based chat.

0

With the latest kernel update Linux X1 3.16.0-55-generic #74~14.04.1-Ubuntu Skype is now working on 3G. Lenovo X1 Carbon 3rd gen.

0

change below settings in 4G modom

tools -> Options -> select connection type NDIS and click OK, now click connect. now skype will work

this is working in AIRTEL 4G dongle

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.