0

Here is the situation:

We have couple of computers in office but only two of them have issues connecting to our company website. Both runs ubuntu.

It's always like this: I can connect to website 3-4 times fine then all TCP packet are retransmitted without success (see screenshot). And for couple of minutes I can't connect to anything TCP-related. Then I can connect. Then again error, loop.

Same error happen with FTP - I can connect to FTP, it works fine for first few commands then it's dead for couple of minutes.

I can ping server constantly with zero issues, we changed router, called ISP, everything is fine.

Issue is strange because of symptoms:

  • issue appears with only that website everything on internet used to works fine for years but on another hand that website works just everywhere even on same computers with windows
  • when I connect to SSH I can stay connected forever. even if I get retransmission errors later on..
  • but if I got retransmission errors before I connecto to SSH I can't connect to SSH anymore!
  • Ping is always fine, so traceroute/mtr
  • Works fine on CentOS server and Windows computers in office
  • Works fine on same ubuntu machines when booted into Windows
  • I disconnected all devices except my work ubuntu laptop, tried, still same issue

This is script I wrote to check does issue exists:

#!/bin/bash

while :
do
    if ! [ $(curl --silent --connect-timeout 1 "our-website.com" | wc -l) -eq 12 ]; then
        echo "ERR"
    else 
        echo "OK"
    fi;

    sleep 1
done

Last test with brand new router gave me 648 x OK, 562 x ERR

Our CentOS server gives me 100% x OK

This was tested on (Ubuntu 14.04.2 LTS):

Linux 3.13.0-55-generic #94-Ubuntu SMP Thu Jun 18 00:27:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

and

Linux 3.16.0-41-generic #57~14.04.1-Ubuntu SMP Thu Jun 18 18:01:13 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

One computer uses default network manager, another one wicd network manager.

I tried other kernels no success.

I also tried to change

sysctl net.ipv4.tcp_sack
sysctl net.ipv4.tcp_syn_retries
/proc/sys/net/ipv4/tcp_retries1

And no success. It might sound like question for server fault but error happens only on Ubuntu so that's why I ask my question here.

You could say this is hosting problem, but no, I talked to hosting a lot, no help. We use shared hosting and none of their customers had similar issue, also I can confirm it works everywhere else.

Please help.

I blurred server's IP address but I decided to publish IP of server/url, here it is: http://88.198.241.36:2222 - after few browser refreshes it stops working, every time

Wireshark

  • Do you have the server side packet capture, whether the packet is reached on server and no response from them? or the packets are not even reaching the server? – Chandrasekar Jun 24 '15 at 12:36
  • @Chandrasekar no I dont and I dont have server root access – Peter Jun 24 '15 at 13:08
  • I tried your script on an ubuntu computer, but I always get 95 lines from the URL you provided. I used an Ubuntu desktop VM on my Ubuntu server and connected to the URL many times without issue. – Doug Smythies Jun 24 '15 at 14:23
  • @DougSmythies actually i use a bit different url (same different page) but issue is same. i ran out of ideas. i i'll download the newest ubuntu and try live CD later on, altrought we always update our system our base installations are quite old (2013-ish) maybe that will help – Peter Jun 24 '15 at 14:26
  • The IP used by ubuntu and Windows (on the same computer) is same? Are you sure there is no firewall rule or something else is blocking the IP of Ubuntu? Since there is no ACK for the SYN packet, I am not sure it is just a problem with this Ubuntu installation. The problem may be either on Server or combination of bother Server and Ubuntu. I think we have to focus, what is happening to the ACKs from Server? Possibly we have to confirm, 1. Packets reached Server or not 2. Server Responded or not 3. If server responded what happened to the ACK pakcets. – Chandrasekar Jun 24 '15 at 15:42
0

Try to set less MTU on your interface:

sudo ifconfig eth1 mtu 1492

I had the same problem and MTU size change allowed to fix this.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.