1

I am using Ubuntu 15.04.

I installed gVim using sudo apt-get install vim-gnome. After installing, I played around with opening and editing files and changing the colorscheme to Solarized.

I then attempted to reset everything to the way it originally was by deleting ~/.vimrc and the entire ~/.vim directory. That successfully removed the Solarized colorscheme I had installed. However, after I did this, the program seemed to retain some strange state that I can't figure out how to change.

When I search for gvim in Dash, the result that comes up is titled foo.txt (~/test/directory/that/...was/playing/with) - GVIM instead of just GVIM. If I run the gVim from that search, lock it to the Launcher, then close the program and hover over the locked icon, similar text is shown (foo.txt (~/test/directory/that/i/was/playing/with) - GVIM), instead of just the program name.

While the program is running (after I start it by Dash search or locked icon), the title shown in the menu bar at the top of the screen is foo.txt (~/test/directory/that/i/was/playing/with) - GVIM, but the title of the window itself is bar.txt (~/test/directory/that/i/was/playing/with) - GVIM (where foo.txt and bar.txt are two different files that I was previously editing in the same directory).

To try to solve this problem, I uninstalled gVim using sudo apt-get remove --purge vim-gnome and sudo apt-get autoremove, then reinstalled it the same way I originally installed it. The problem seemed to have disappeared at first, but after logging out of and then back into my account, everything appeared to be exactly the way it was before I reinstalled gVim.

One of the tiny details that I found irritating about gVim was that the icon displayed in the Alt-Tab menu is horribly low-resolution. Strangely, immediately after I reinstalled it, the icon shown in the Alt-Tab menu looked nice and high-resolution. After logging out of and back into my account, though, it had returned to its previous low-resolution self.

Upon running ls -a in my home directory, I noticed a file called .viminfo which contained the text test/directory/that/i/was/playing/with/bar.txt, so I thought that that file might be the source of my problems. I tried deleting the file in multiple different ways and restarting gVim, but every time I did so, it reappeared with the exact same contents.

I can't find any information about this problem. Does anyone know how to remove those filenames that seem to have baked themselves into the program and restore the Alt-Tab icon to its proper resolution?

Update: As suggested by muru, I tried adding a ~/.gvimrc file with the text set notitle. This didn't affect my main problem, which is that the name of a recently edited file seems to have elevated itself to the status of the gVim program name. I also tried deleting /etc/vim (and then putting it back when that didn't work). I don't understand how this could happen, but I'm guessing that it's not something that can be fixed by just editing some text file contents; I don't see how such an edit could change the displayed name of the program itself. Am I incorrect in that assumption?

  • Is there a .gvimrc file in your home directory? What about /etc/vimrc, and files in /etc/vim/? – muru Jun 24 '15 at 1:10
  • There is no ~/.gvimrc file and no /etc/vimrc file. There is a /etc/vim directory with files gvimrc, vimrc, and vimrc.tiny. Should I delete the /etc/vim directory? – Sam Estep Jun 24 '15 at 1:31
  • If you're the only user, I suppose you could, but it would be easier to override these files using your own .gvimrc. For example, set notitle in ~/.gvimrc should stop GVim from using the filename in the title. Wht does grep title /etc/vim -R say? – muru Jun 24 '15 at 1:34
  • I am the only user. Creating ~/.gvimrc with the line set notitle causes the window title to display as Vim, but the title shown in the menu bar, the hover text in the launcher, and the title in the Dash search results remain the same. grep title /etc/vim -R returns nothing. – Sam Estep Jun 24 '15 at 1:39
  • 1
    @Seth OK; I wasn't sure before whether it was completely on topic here, so I suggested moving it, but if you think that it is on topic, I'd like to keep it here. Thanks! – Sam Estep Jun 25 '15 at 12:25
0

Deleting the programs files does not remove or reset the program.

In order to completely remove the program you must uninstall the program, and then reinstall it.

To do this you must:

Uninstall the program. To do this you must first open the terminal. To do this press:

ctrl + alt + T

The terminal window should now be open. To uninstall it type the following command:

sudo apt-get --purge remove vim-gnome

This may ask you to enter your password, then it will completely remove the program.

Reinstall the Program To do this simply type:

sudo apt-get install vim-gnome

Again you may need to enter your password.

Once this is finished you are finished.

  • 1
    I've already gone through this exact process multiple times (and tried it twice more after your post just to be sure) and it didn't fix any of the problems in my question. I'm updating the question to note that I have tried the --purge option. – Sam Estep Jun 25 '15 at 1:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.