3

I recently bought a new HP pavilion 15 (has windows 8) and installed (dual boot) a fresh version of ubuntu 14.04 (64bit).

After installation, the built-in wifi wasn't working so i used a usb wifi stick to connect to Internet. Few minutes later, i tried the built-in wifi and it started working fine.

However i noticed that it gets disabled after i suspend and re-relogin. The wifi switch gets greyed and can't click it anymore and i see the message "wifi is disabled by hardware switch), although there's no hardware switch in this HP.

The only solution to get the wifi back is by restart (and that's really annoying).

I spent days trying solutions that i found for similar problems in this forum and other websites but with no luck.

The sudo rfkill list all displays the following:

2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

The unblock command doesn't change anything.

(wifi works well on windows)

Please help me find a solution for this problem.

1
  • Hi, Do you have the solution for this? I'm also affected by this problem. – amru Jan 20 '16 at 16:57
1
#!/bin/sh

case "${1}" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on;
esac

Put this in /etc/pm/sleep.d/10_resume_wifi and the problem should be fixed immediately.

2
  • It didn't work unfortunately. – Jean Jun 23 '15 at 21:59
  • in my case, nm was just disabling wifi on resume ( 14.04) . it worked after fixing command to nmcli nm wifi on; ( command "r" didn't exist) – UnX Apr 1 '16 at 22:24
0

Type the following commands in terminal

sudo rmmod -f rt2500usb<br>
sudo rfkill unblock all<br>
sudo modprobe rt2500us<br>
rfkill list all

If this doesn't work, then type in terminal

sudo service network-manager restart

But you have to do the second method every time your wireless is being diabled

5
  • it didn't work too – Jean Jun 23 '15 at 22:00
  • I hope you have tried the second method in my answer(sudo service network-manager restart) which should mostly work. If that too doesn't work, then try sudo service networking restart – spharish Jun 24 '15 at 5:13
  • I did. it just restarts the network, but wifi remains disabled. – Jean Jun 24 '15 at 8:18
  • What is the output of rfkill list – spharish Jun 24 '15 at 13:52
  • brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: yes – Jean Jun 25 '15 at 8:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.