1


I recently installed Kubuntu 15.04 64bit on my laptop, precisely an Asus UX32VD (it has got 2 graphic cards, Nvidia geforce 620m and Intel). Everythings works fine as it was with Kubuntu 14.10, but now I have a great issue, that is when I close the lid nothing happens. As I set from the kde power manager when I close the lid my laptop should be suspended but this doesn't happen, so the laptop screen remains on.
I searched for a long a solution on internet, but nothing allowed me to solve the problem, so I was forced to open this ask on askubuntu.com. For example I try to:
1. install nvidia restricted driver using ppa: xorg-edgers (preciselly nvidia-352 version);
2. install pm-utils and laptop-mode-tools
This is my xorg configuration if it returns useful for you:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "intel"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "SNA"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Finally I would point out that If I try to manually suspend the system, it works. I hope some of you can help me please, also because I'm scared to leave my laptop in bag while it is turned on again. Thank you in advance

  • Please check your BIOS settings to ensure that this feature is enabled in the BIOS. If it is not, no settings in Ubuntu will permit that feature to work. I should also mention that I've been using Ubuntu for about a decade now and have installed and configured Ubuntu on well over 100 computers, most of them laptops, and I've found the suspend feature of Ubuntu to be problematic with sufficient frequency that I generally recommend against using it. Instead, I remind my users to take heart in the fact that Ubuntu shuts down and starts up faster than most any other OS, including Mac. – gyropyge Jun 23 '15 at 13:08
  • There was never any settings in the bios on laptops that would manage the closing of the lid. So the cause of issue is Kubuntu, In fact the suspension works on windows – tuxj Jun 23 '15 at 13:27
  • That's a broad statement, and quite untrue. I have several laptops with such settings in bios and if you like I can photograph the screens of such laptops with such settings and email you the pictures. As for the fact it works in windows and not in kubuntu should be a clue. Prior to using Ubuntu full time, I used Kubuntu for one year and discovered there are quite a lot of "bugs" it has not common to Ubuntu. Curious, I looked into it and guess what, MICROSOFT contributes to Kubuntu, so my guess they intentionally undermine it. I recommend you try using ACTUAL UBUNTU. – gyropyge Jun 23 '15 at 14:05
0

This may sound obvious, but have you tried the following?

Kmenu > Settings > System Settings > Advanced > Power Management > Edit Profiles

Sorry if I was no help at all ¯_(ツ)_/¯

  • I haven't "Edit profiles" option on my Energy Saving application. Maybe you think that I'm using Kubuntu 14.10, and not Plasma 5 (probably it's different). – tuxj Jun 24 '15 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.