I have shared a folder on my ext4 drive mounted at /media/data using the GUI.

enter image description here

Now it appears in my Places -> Network and I'm able to access it, after giving password, at smb://wim-ubuntu/ab/

However in windows I can't access the share, they see this error:

enter image description here

I have tried creating a user on the Ubuntu machine with username/password which match what the windows user has, but no joy... what am I missing?

The 'diagnose' button on windows doesn't really offer anything useful, it says that the location WIM-UBUNTU exists but the share can not be found.

  • Does ping win-ubuntu work? Does ping ipmachine work? – DavidEG Oct 2 '11 at 11:14
  • yes, they both work. – wim Oct 2 '11 at 12:11
  • Maybe some firewall is causing problem. Try after disabling any firewalls you have in both machines. Try if you can connect using telnet to the smb ports: telnet ipmachine 137, telnet ipmachine 138,telnet ipmachine 139, telnet ipmachine 445 – DavidEG Oct 2 '11 at 14:38
  • I don't have a firewall on my machine, and I don't think there can be a firewall problem because I can see (and write to) the windows shares. It's just the windows machine can't see here. – wim Oct 3 '11 at 10:02
  • Did you try this? it worked for me. ubuntuforums.org/showthread.php?t=1797058 – user42383 Jan 17 '12 at 16:33

On way of doing it is to add the shares in /etc/samba/smb.conf with the following format.

         path = /media/yourshare

If you are having problems with login you can allways use this to test if the samba server works.

guest account = yourusername
guest ok = yes

But these should only be used for testing, because it disables your security, and tells samba that all the guest's are you.

Some other usefull parameters/settings are:

read only = yes
valid users = yourusername

When you have the configuration file as you like, restart the samba deamon.

sudo service smbd restart
  • i tried this, but the windows user still get the same dialog... do i need to restart the ubuntu machine or anything to get changes to take effect? – wim Oct 2 '11 at 12:12
  • you have to restart the samba server. "sudo service smbd restart" – filescraps Oct 2 '11 at 16:29
  • I have tried your suggestion but the same dialog persists for the windows user. Anymore ideas..? – wim Oct 3 '11 at 10:04
  • Have you removed your original nautilus share?, so they don't overlap. – filescraps Oct 3 '11 at 11:05

I had same problem. Dyugle wrote this solution:

gtksu gedit /etc/samba/smb.conf

add to [global]

force user = username

UserName must be a user which has rights on folders.

  • 1
    If you have the original solution, it is often handy to link it in your post as a reference, as the original author might have covered some things that your example may not have which could help other users. – somoso Apr 26 '13 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.