4

I understand this is very similar to this question and this one, but none of the answers there have worked for me. When trying to install the packages mentioned in those questions, apt-get throws up the following error message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 unity-webapps-service : Depends: webapp-container
E: Unable to correct problems, you have held broken packages.

When I try to install the dependencies mentioned there, I just find more and more dependencies. Synaptic Package Manager gives error messages when I select 'Fix Broken Packages'. How can I fix this?

Thanks in advance, and please comment if you need more information.

UPDATE: Running apt-cache policy webapp-container unity-webapps-service gave the following result:

webapp-container:
  Installed: (none)
  Candidate: 0.23+14.04.20140428-0ubuntu1
  Version table:
     0.23+14.04.20140428-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     0.23+14.04.20140414-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
unity-webapps-service:
  Installed: (none)
  Candidate: 2.5.0~+14.04.20140409-0ubuntu1
  Version table:
     2.5.0~+14.04.20140409-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

UPDATE 2: Version information:

LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:    14.04
Codename:   trusty

UPDATE 3: When trying to install unity-webapps-service using aptitude instead of apt-get:

The following NEW packages will be installed:
  liboxideqt-qmlplugin{a} liboxideqtcore0{a} liboxideqtquick0{ab} 
  libqt5feedback5{a} libqt5multimedia5{ab} libqt5organizer5{ab} 
  libqt5positioning5{ab} libunity-webapps0{a} 
  qtdeclarative5-dialogs-plugin{ab} 
  qtdeclarative5-privatewidgets-plugin{ab} 
  qtdeclarative5-qtfeedback-plugin{a} 
  qtdeclarative5-ubuntu-ui-extras-browser-plugin{a} 
  qtdeclarative5-ubuntu-ui-toolkit-plugin{ab} unity-webapps-qml{a} 
  unity-webapps-service webapp-container{ab} webbrowser-app{ab} 
0 packages upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.6 MB of archives. After unpacking 103 MB will be used.
The following packages have unmet dependencies:
 webapp-container : Depends: qtdeclarative-abi-5-2-1 which is a virtual package.
 libqt5organizer5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 qtdeclarative5-dialogs-plugin : Depends: qtbase-abi-5-2-1 which is a virtual package.
                                 Depends: qtdeclarative-abi-5-2-1 which is a virtual package.
 webbrowser-app : Depends: qtdeclarative-abi-5-2-1 which is a virtual package.
 qtdeclarative5-privatewidgets-plugin : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5multimedia5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 libqt5positioning5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
 liboxideqtquick0 : Depends: qtdeclarative-abi-5-2-1 which is a virtual package.
 qtdeclarative5-ubuntu-ui-toolkit-plugin : Depends: qtbase-abi-5-2-1 which is a virtual package.
                                           Depends: qtdeclarative-abi-5-2-1 which is a virtual package.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:           
1)      liboxideqt-qmlplugin [Not Installed]                          
2)      liboxideqtcore0 [Not Installed]                               
3)      liboxideqtquick0 [Not Installed]                              
4)      libqt5feedback5 [Not Installed]                               
5)      libqt5multimedia5 [Not Installed]                             
6)      libqt5organizer5 [Not Installed]                              
7)      libqt5positioning5 [Not Installed]                            
8)      libunity-webapps0 [Not Installed]                             
9)      qtdeclarative5-dialogs-plugin [Not Installed]                 
10)     qtdeclarative5-privatewidgets-plugin [Not Installed]          
11)     qtdeclarative5-qtfeedback-plugin [Not Installed]              
12)     qtdeclarative5-ubuntu-ui-extras-browser-plugin [Not Installed]
13)     qtdeclarative5-ubuntu-ui-toolkit-plugin [Not Installed]       
14)     unity-webapps-qml [Not Installed]                             
15)     unity-webapps-service [Not Installed]                         
16)     webapp-container [Not Installed]                              
17)     webbrowser-app [Not Installed]                                



Accept this solution? [Y/n/q/?]

UPDATE 4: The output of sudo apt-get install qtdeclarative-abi-5-2-1:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package qtdeclarative-abi-5-2-1 is a virtual package provided by:
  libqt5qml5 5.2.1-3ubuntu15.1 [Not candidate version]
  libqt5qml5 5.2.1-3ubuntu15 [Not candidate version]

E: Package 'qtdeclarative-abi-5-2-1' has no installation candidate

The output of sudo apt-get install unity-webapp-container:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package unity-webapp-container

UPDATE 5: Output of apt-cache policy libqt5qml5:

libqt5qml5:
  Installed: 5.3.0-3ubuntu13~trusty1
  Candidate: 5.3.0-3ubuntu13~trusty1
  Version table:
 *** 5.3.0-3ubuntu13~trusty1 0
        500 http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     5.2.1-3ubuntu15.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     5.2.1-3ubuntu15 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Output of sudo apt-get install webapp-container:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 webapp-container : Depends: qtdeclarative-abi-5-2-1
                    Depends: unity-webapps-qml but it is not going to be installed
                    Depends: webbrowser-app (= 0.23+14.04.20140428-0ubuntu1)
E: Unable to correct problems, you have held broken packages.
23
  • run & post - apt-cache policy webapp-container unity-webapps-service – doug Jun 22 '15 at 17:56
  • @doug I have updated my post with the output. – thesdog Jun 22 '15 at 21:28
  • Well then try to specifically install unity-webapps-service as in sudo apt-get install unity-webapps-service (- are you running Ubuntu 14.04 or something else? - lsb_release -a – doug Jun 23 '15 at 0:31
  • @doug Trying to install unity-webapps-service gives me the error at the top of my question! And yes, I'm running Ubuntu 14.04.2 LTS. – thesdog Jun 23 '15 at 16:12
  • 1
    @doug said in the chat: It's that ppa you are using that has updated some qt libs that aren't compatible with the Ubuntu packages you are trying to install. So either live without them & the tweak package or use ppa-purge on the ppa. – thesdog Jul 10 '15 at 20:42
6
+50

I'll risk it and leave a response.

A main problem seems to be the PPA ppa:mscore-ubuntu/mscore-stable. With this PPA you can't use the needed version of libqt5qml5

Therefore remove the PPA with the following command.

sudo ppa-purge ppa:mscore-ubuntu/mscore-stable

After that

sudo apt-get install -f

and finally

sudo apt-get install unity-webapps-service

Where is the problem?

The command apt-cache policy libqt5qml5 returns the following. The PPA ppa:mscore-ubuntu/mscore-stable installs a newer version (5.3.0) for libqt5qml5 but qtdeclarative-abi-5-2-1 needs exact version 5.2.1.

libqt5qml5:
  Installed: 5.3.0-3ubuntu13~trusty1
  Candidate: 5.3.0-3ubuntu13~trusty1
  Version table:
 *** 5.3.0-3ubuntu13~trusty1 0
        500 http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     5.2.1-3ubuntu15.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     5.2.1-3ubuntu15 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Side effects

Purging the PPA downgrades the packages installed by the PPA. If a downgrade isn't possible, because a package only exists in this PPA, the package will be removed. The configuration files of the package still exists in your system after the removal.

1
  • Comments are not for extended discussion; this conversation has been moved to chat. – Seth Sep 2 '15 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.