0

My WiFi went down as I was upgrading. Now, when I try to update software, I get an error message stating that I am not authorized to install or uninstall software. I cannot access synaptic. I searched through other partial upgrade threads and eventually removed a package called brllty. This, however did nothing. I tried purging, dpkg does not work, autoremove, clean and a number of other things. I simply cannot get the 344 held packages either off my system or to upgrade. The last thing I tried is apt-get dist-upgrade and this is the error message I got.

alexander@alexander-HP-14-Notebook-PC:~$ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree
Reading state information... Done Calculating upgrade... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libcogl15 : Depends: libegl1-mesa-drivers xul-ext-webaccounts : Depends: webaccounts-extension-common (= 0.5-0ubuntu2) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Any assistance would be greatly appreciated as I have no idea what to do. Thanks.

0

I would verify that /etc/apt/sources.list is set for utopic.

Then I would apt-get remove every package that has unmet dependencies when apt-get dist-upgrade launched. (so, remove libcogl15)

System should not be restarted when some essential packages like linux-image, core-utils, etc are not installed (otherwise there will be some fun with booting from USB and using chroot to install packages; or plain reinstall). But I think that it won't go so far.

Then, after successful apt-get dist-upgrade, I would clean up unused packages (it is apt-get clean, maybe).

If it destroys the desktop environment, then it can be brought back by installing the ubuntu-desktop package.

If something is missing, then search/install as usual.

If lots of stuff is missing, then there is a list of packages from which the Ubuntu 14.10 Install ISO image is made. Install them all.

  • My sources were set for utopic. Removed libcogl15 and then ran apt-get update. After this I ran apt-get dist-upgrade and it worked fine. Thanks very much for your help! – Alexander Gomm Jun 27 '15 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.