2

I wanted to upgrade from Ubuntu 14.04 LTS to the new Ubuntu 15.04 on my Dell XPS 14 2015 Developer Edition, because most issues seemed to be fixed in the live version.

Therefore I wiped the hole disk (without doing it easier) and now the XPS isn't able to find any bootable media. Then I tried to install it with the help of this guide which gave me the hint to create a new partition table.

The installation worked fine and I saw in the live version of Ubuntu that the system and my account under /home was installed.

But the notebook still can't find any bootable media. Are there any other aspects that I didn't consider?


Update:

The problem could be solved by enabling UEFI booting in the BIOS (press F12 during the boot) and by disabling 'Legacy option ROMS'. Take a look at this DELL blog post. Follow the instructions and reinstall your system.

2
  • It seems to be issue with the version of ubuntu in dell xps which causing many issues like often hanging and freezing. – vembutech Jun 22 '15 at 12:42
  • @vembutech do you mean Ubuntu 14.04? – user3147268 Jun 22 '15 at 12:54
1

It is possible that GRUB is not installed or corrupted. Try installing grub again if you can login through coomand line (CTRL + ALT + F1).

11
  • I found this article to install GRUB on my machine. I tried the command sudo grub-install /dev/sda but I get an error: Ìnstalling for i386-pc platform grub-install: error: failed to get canonical path of '/cow' – user3147268 Jun 22 '15 at 12:54
  • @user3147268 check the following link – neha Jun 22 '15 at 13:08
  • I tried the commands under If Your Grub Partition Contains A Full OS Install: sudo mount /dev/sda1 /mnt returns that /dev/sda1 is already mounted at /mnt. Next I entered sudo chroot /mnt and I got an error: chroot: failed to run command '/bin/bash': no such file or directoy. How is possible? Currently I'm using the default bash console. – user3147268 Jun 22 '15 at 13:18
  • 2
    The reference to i386-pc strongly suggests that the system was installed in BIOS/CSM/legacy mode, or at least that your recovery medium was booted that way. Chances are you should be using an EFI/UEFI-mode install instead, since that's the native mode for essentially all modern firmware. Enabling BIOS/CSM/legacy support complicates the boot path and creates opportunities for problems such as the one you describe, as covered in more detail on my Web page on the subject. – Rod Smith Jun 22 '15 at 13:22
  • @user3147268 Give it a shot to these commands. When I was in a similar situation and nothing worked ,only this solution fixed grub installation. sudo mkdir /mnt/boot sudo mount -t auto /dev/sda1 /mnt/boot sudo grub-install --root-directory=/mnt/boot --recheck /dev/sda – neha Jun 22 '15 at 13:33
0

This solution worked for me https://help.ubuntu.com/community/Boot-Repair

1) Launch ubuntu on the live USB

2) follow the procedure to install Boot-Repair

3) Restart and your system will boot

4) From terminal update, upgrade and dist-upgrade and reboot

5) repeat 4) id you find some issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.