0

I recently ordered an Intel NUC 5i5RYH with a Samsung Evo SSD and 2 x 8GB GB Crucial RAM.

I attempted to install Ubuntu 14.04 on it but I had problems with it suspending before I could even finish the installation process. It would just suspend for no apparent reason. I even sat there moving the mouse through the whole process to try to prevent it, but it still suspended.

I read somewhere that 15.04 works better with the NUCs and several reports of Xubuntu working, so I gave that a shot (64 bit version). I did at least manage to get it installed and working, but it still randomly suspends. Sometimes it suspends immediately upon booting, other times I can use it for five or ten minutes before it suspends. It does this even though I have set it to never suspend in the power settings.

One thing I've noticed is that when I was trying to install Chrome, it always suspended when going to google.com/chrome, even though I was able to navigate to several other sites (this one included) without apparent issue. It does this on Chromium and Firefox.

But I don't have to go to that site for it to suspend. It does it eventually no matter what. Even if I'm not logged into the GUI. It will suspend if it sits on the login screen for a while, or if I hit F6 and use the terminal there.

Once it suspends it won't wake back up no matter what I do.

I can confirm that the computer is suspending, as opposed to running along but not sending output to the display, because I also lose SSH access when this happens.

I've tried enabling and disabling secure boot. No change. Before I realized I couldn't shell into it, I thought it might be an issue with the display and installed mesa-vdpau-drivers as described in this question. No change. I read that it can suspend due to overheating, so I tried changing the fan settings to more aggressively cool the CPU. No change.

I'm about ready to call the dang thing defective and send it back. However, I'm really hoping that there's a software fix somewhere. Or short of that, I'd like to know if there's a way I can diagnose the hardware problem. Any help is, of course, much appreciated.

0

How do you know it suspends? Can you wake it up somehow ? You write you can't right ? Seems more like freezing. How about memory problem ? Try to run mem test. Most of distros have it on live cd. Check the volage of you memory chips. Maybe try to install xubuntu with just one memory plate.

I have xubuntu runnig in production NUC for about year and I didn't see any freeze up yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.