0

I'm having a problem with booting into Ubuntu 14.04 through my GTX 970 graphics card. I had installed it previously onto my system along with the NVIDIA driver and it was working fine for the most part despite some hiccups but I recently tried to update some drivers but it didn't update correctly. I can't boot correctly anymore; all I get is either a black screen or a a screen with a text blinker on it (the proper name for it escapes me at the moment). I can get to the GRUB menu sometimes and have tried to update but get the errors shown here: errors. Entering through recovery mode can get me to the login screen but trying to login just brings me back to the login screen! I don't have much experience in fixing Ubuntu in this way so please help if you can. I have tried other solutions but they haven't seemed to work for me.

2

3 Answers 3

0

I had the same problem for a while with my GTX 970 and I fixed it by using the boot-repair.

First you need to somehow get the ubuntu to boot in recovery mode. If that doesn't work try logging into the shell by pressing Ctrl+Alt+F3

Once you log in, then you should run boot repair: https://help.ubuntu.com/community/Boot-Repair

For some reason, everytime I use the GTX 970 driver to run my monitors, I had to do boot-repair...

4
  • I installed boot-repair but trying to use it gives me: Gtk-WARNING **: cannot open display
    – chompbits
    Jun 22, 2015 at 3:26
  • can you in any way login to recovery mode without using shell? I had the exact same problem and it took me a day to fix it. I think I tried to login to recovery mode again and again and used boot-repair to finally fix it. Just bear with me and try to login with recovery mode.
    – JayC
    Jun 22, 2015 at 13:58
  • Unfortunately, I ended up having to resort with the nuclear option and completely reinstalled Ubuntu since nothing was working (was not able to do TNT's method since I did it before it was posted). If this occurs again, I'll be sure to try this again and see what happens.
    – chompbits
    Jun 25, 2015 at 0:53
  • After you install your GTX970 driver, don't forget to do ubuntu boot repair!
    – JayC
    Jun 25, 2015 at 0:55
0

I had virtually the same problem on the same system: Ubuntu 14.04 with GTX 970.

I had installed the NVIDIA drivers from the website. What worked for me in the end was:

  1. Go to recovery mode (graphics fail safe mode)

  2. Enter Terminal (Ctrl+ALT+F1)

  3. sudo stop lightdm (or was it: sudo service lightdm stop )

  4. Run the original installer file

    sudo NVIDIA.your version here.run --update

Note: it seems like a flaky and bothersome solution considering this appears to be a common problem. However, just uninstalling the driver with the script didn't fix my problem (maybe I forgot to stop lightdm beforehand?). If it works for you, I suggest uninstalling and switching to the open drivers by installing

sudo apt-get install nvidia-current-updates nvidia-settings-updates

(not sure where I saw that)

-1

I just turn off secure boot in the BIOS.

1
  • Please edit your answer to include more details, or else it should have been a comment.
    – cat
    Jan 21, 2016 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .