4

I installed ubuntu 14.04.02 on a new macbook pro 11,5 (15 inch), but wifi doesn't work.

Here are some information about the wifi adapter.

$ lspci -nn | grep 0280
04:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:43ba] (rev 01)

$ sudo lshw -C Network
*-network
description: Network controller
product: Broadcom Corporation
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=wl latency=0
resources: irq:18 memory:b0800000-b0807fff memory:b0400000-b07fffff

I followed the answers of the following questions, wifi still doesn't work. I tried many times, the final results are the same.

  1. wifi doesn't work on Macbook pro 15 of ubuntu 14.04 LTS

  2. WIfi Issues with Macbook Pro Retina Early 2015 (12,2) on Ubuntu 15.04

  3. How to get Wifi working on Ubuntu 14.04 (Macbook Pro Retina 15 inch - 2014)

I didn't see the chipset id, but I think [14e4:43ba] should be the pid:vid of wifi adapter. I didn't see much discussion about this device. Hope anyone can share your experience of how do you get this work.

Thanks in advanced!

PS: I have a usb to ethernet adapter, I finished apt-get update and upgrade, it doesn't help.

3 Answers 3

3

You need to uninstall wl driver by

sudo apt-get purge bcmwl-kernel-source

Copy brcmfmac43602-pcie.bin to /lib/firmware/brcm.

But if you updated your system, this file should be already there in 14.04.

Reboot and make sure that command lspci -knn | grep Net -A2 gives output

Kernel driver in use: brcmfmac
4
  • Thanks! After updated the system, I can see brcmfmac43602-pcie.bin and brcmfmac43602-pcie.ap.bin under /lib/firmware/brcm. But I didn't install bcmwl-kernel-source, and when I try to uninstall, I can see this log 'Package 'bcmwl-kernel-source' is not installed'. After reboot wifi driver is still not detected $ lspci -knn | grep Net -A2 04:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:43ba] (rev 01) Subsystem: Apple Inc. Device [106b:0152] 05:00.0 Multimedia controller [0480]: Broadcom Corporation Device [14e4:1570].
    – Seinlin
    Commented Jun 22, 2015 at 1:37
  • Please post additional information to your question, not to comments. @Seinlin
    – Pilot6
    Commented Jun 22, 2015 at 8:03
  • This worked for me. I also copied over brcmfmac43602-pcie.ap.bin just in case. Note, my macbook locks on shutdown and suspend. I suspect it may be due to these drivers.
    – msdin
    Commented Jul 3, 2015 at 0:52
  • Note that if you compile the kernel from source, you need to enable PCIE bus support. See unix.stackexchange.com/questions/225216/…
    – lily
    Commented Aug 27, 2015 at 6:11
1

You have to upgrade your Ubuntu 14.04:

sudo apt-get update
sudo apt-get upgrade

And also install at least a 3.17 kernel (Broadcom brcmsmac(PCIe) and brcmfmac(SDIO/USB) drivers):

sudo apt-get install linux-generic-lts-vivid

You can check your kernel version with:

uname -r

Reboot and the wifi adapter should be fine! (My wifi is working in a Macbook 11,5 - 2015 15" Retina)

1
  • Thanks, this got WiFi working on 14.04 on my 2015 Macbook Pro! Picking the driver in the Ubuntu software dialog never worked, but your commands did. Commented Dec 15, 2015 at 17:41
-1

Upgrade your kernel to the latest version. I used 4.1 with Linux Mint 17.2 on the MacBook Pro 13 early 2015 with the exact same chip. The device manager still shows a warning, but the driver works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .