1

I'm trying to set up MAAS with about 8 nodes and I've been doing the automatic install through PXE which works great. Problem is, every time I restart the machines through the MAAS web ui, the node re-installs the OS through PXE. Should I be disabling PXE after the node is up and running so that it doesn't re-install every time?

Reason I ask is, I don't see this listed in the documentation anywhere, so I'm not sure whether it's a good idea to disable PXE on that machine. Am I doing something wrong?

Edit #1 - BTW if I change the boot priority to set the PXE as the second boot, it drops me into the busybox mini shell and fails to start up.

Edit #2 Solution - Ended up having to set the rootdelay=90 on the kernel line of the boot loader and then setting the PXE boot to a lower priority fixes my issues.

Thanks!

1

Instead of disabling PXE boot altogether, just move the PXE boot a notch lower in the boot priority and then the systems will boot normally and will only start re-install when needed.

| improve this answer | |
  • As you're a reputation 1 user: If this answer helped you, don't forget to click the grey at the left of this text, which means Yes, this answer is valid! ;-) – Fabby Jun 21 '15 at 8:28
  • That was my first thought, but I get another error stating something along the lines of "Gave up waiting for root device....." and drops me into a mini-shell. I know the problem has to do with setting the root delay in the grub bootloader, but I can't for the life of me figure out how to get to the point where I can modify the grub cfg. (I'm still sitting on the screen which shows the "Gave up waiting for root device") – h0mer Jun 21 '15 at 8:59
  • Could you edit your question to provide this crucial information, please? – Fabby Jun 21 '15 at 9:08
  • Never mind. I figured it out. Set the rootdelay=60 in the kernel startup and then changed it in the grub and updated it. Going to suck if I have to do this on every machine everytime I have to re-install Ubuntu on a node. Can't believe I wasted 4 hours on this problem. – h0mer Jun 21 '15 at 9:09
  • 1
    Even better! Post your own answer! And the next guy/girl on the block will not have to waste 4 hours! (on a Sunday!!!) ;-) – Fabby Jun 21 '15 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.