-1

I cleaned my laptop fan today, having to remove my hard disk. Now, grub is missing : my laptop boots on windows automatically. I had a debian testing - windows dualboot.

Boot Mode : [UEFI]

Secure boot [Disabled]

Network Boot; F12 Boot Menu; D2D Recovery; Wake on LAN are all [Disabled]

Sata Mode : [AHCI Mode]

And windows fastboot is desactivated.

I have tried Boot-repair on an ubuntu live session but it doesn't work, it prints : 'grub-efi purge cancelled. Please report this message to boot.repair@gmail.com'

Here is my boot info : http://paste.ubuntu.com/11742170/

What can i do? Thanks for helping me.

closed as off-topic by karel, Fabby, Pilot6, A.B., Eric Carvalho Jun 21 '15 at 20:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – karel, Fabby, Pilot6, A.B., Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Which boot option is selected in UEFI? – luckyrumo Jun 19 '15 at 22:14
  • We're sorry, but this site is all about Ubuntu and its official derivatives as posted on wiki.ubuntu.com/Releases so Debian is unfortunately off-topic here as well. However, on unix.stackexchange.com, a sister site to Ask Ubuntu, they're very good at all varieties of Linux and Unix, so you might be better off there. ;-) – Fabby Jun 20 '15 at 23:41
  • I understand this topic is about ubuntu but since it concerns grub i assumed it worked the same way for debian or ubuntu. So someone using ubuntu may experience the same issue, isn't it right ? – Keho Jun 22 '15 at 9:13
  • the pre-existent debian tag should be destroyed then ;P – Keho Jun 22 '15 at 9:28
1

I solved it with the tip at the end of the boot info :

I used bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi

but i have to do it every time i restart my computer -_-'

Not the answer you're looking for? Browse other questions tagged or ask your own question.